lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: 28 May 2007 19:43:15 -0000
From: securityresearch@...vigilance.com
To: bugtraq@...urityfocus.com
Subject: DGNews version 2.1 XSS Attack Vulnerability

	netVigilance Security Advisory #23

DGNews version 2.1 XSS Attack Vulnerability
Description:
DGNews is small and simple but powered news publishing. Easy installation, no programing required. But you can still change whatever you want (for advanced users). Features: add unlimited categories, automatic news image thumbnailed, click count, user comment, print view and many others. Include full lay out, but sure, you can modify what you need.

This vulnerability can be exploited only when PHP register_globals = On.

External References: 
Mitre CVE: CVE-2007-0694
NVD NIST: CVE-2007-0694
OSVDB: 34228

Summary: 
DGNews is small and simple but powered news publishing.
Security problem in the product allows attackers to conduct XSS attacks.

Advisory URL: 
http://www.netvigilance.com/advisory0023
Release Date:
05/28/2007

Severity:
Risk: Medium
 
CVSS Metrics:
Access Vector: Remote
Access Complexity: High
Authentication: Not-required
Confidentiality Impact: Partial
Integrity Impact: Partial
Availability Impact: Partial 
Impact Bias: Normal
CVSS Base Score: 5.6
 
Target Distribution on Internet: Low
 
Exploitability: Functional Exploit
Remediation Level: Workaround
Report Confidence: Uncorroborated
 
Vulnerability Impact: Attack
Host Impact: XSS Attack

SecureScout Testcase ID:
TC 17953

Vulnerable Systems:
DGNews version 2.1

Vulnerability Type:
XSS (Cross-Site Scripting) to force a web-site to display malicious contents to the target, by sending a specially crafted request to the web-site. The vulnerable web-site is not the target of attack but is used as a tool for the hacker in the attack of the victim.

Vendor:
Dian Gemilang
Vendor Status: 
The Vendor has been notified several times on many different email addresses last on 14 May 2007. The Vendor has not responded. There is no official fix at the release of this Security Advisory.

Workaround:
In the php.ini file set register_globals = Off. 
Example: 

REQUEST:
http://[TARGET]/[PRODUCT-DIRECTORY]/footer.php?
copyright=<script>alert(document.cookie)</script>
REPLY:
Will execute <script>alert(document.cookie)</script>
Credits: 
Jesper Jurcenoks
Co-founder netVigilance, Inc
www.netvigilance.com

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux - Powered by OpenVZ