lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 29 Nov 2017 14:45:13 +1030
From: Matthew Hart <mhart@...assian.com>
To: bugtraq@...urityfocus.com
Subject: Advisory - Hipchat Data Center, Hipchat Server - CVE-2017-14585

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

This email refers to the advisory found at
https://confluence.atlassian.com/x/MXEGO .


CVE ID: CVE-2017-14585.


Products: Hipchat Data Center, Hipchat Server

Affected Hipchat Data Center product versions: 3.0.0 <= version < 3.1.0
Affected Hipchat Server product versions: 2.2.0 <= version < 2.2.6

Fixed Hipchat Data Center product versions: Hipchat Data Center 3.1.0
has been released with a fix for this issue.
Fixed Hipchat Server product versions: Hipchat Server 2.2.6 has been
released with a fix for this issue.

Summary:
This advisory discloses a critical severity security vulnerability that was
introduced in version 3.0.0 of Hipchat Data Center and version 2.2.0
of Hipchat Server.

Versions of Hipchat Data Center starting with versions of Hipchat Data
Center from 3.0.0 but less than 3.1.0 (the fixed version) are affected
by this vulnerability.

Versions of Hipchat Server starting with versions of Hipchat Server
from 2.2.0 but less than 2.2.6 (the fixed version) are affected by
this vulnerability.


Customers who have upgraded Hipchat Data Center to version 3.1.0 are not
affected.

Customers who have upgraded Hipchat Server to version 2.2.6 are not affected.

Customers who have downloaded and installed Hipchat Data Center >= 3.0.0 but
less than 3.1.0 please upgrade your Hipchat Data Center installations
immediately to fix this vulnerability.

Customers who have downloaded and installed Hipchat Server >= 2.2.0 but less
than 2.2.6 please upgrade your Hipchat Server installations immediately to fix
this vulnerability.

Remote code execution in Hipchat Server and Hipchat Data Center - CVE-2017-14585

Severity:
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
environment.


Description:

A Server Side Request Forgery (SSRF) vulnerability could lead to
remote code execution for authenticated administrators.

Versions of Hipchat Data Center starting with versions of Hipchat Data
Center from 3.0.0 but less than 3.1.0 (the fixed version) are affected
by this vulnerability.

Versions of Hipchat Server starting with versions of Hipchat Server
from 2.2.0 but less than 2.2.6 (the fixed version) are affected by
this vulnerability.

This issue can be tracked at: https://jira.atlassian.com/browse/HCPUB-3526 .


Fix:

To address this issue, we've released the following versions containing a fix:

* Hipchat Data Center version 3.1.0
* Hipchat Server version 2.2.6


Remediation:

Upgrade Hipchat Data Center to version 3.1.0 or higher, upgrade
Hipchat Server to version 2.2.6 or higher.

The vulnerabilities and fix versions are described above. If affected, you
should upgrade to the latest version immediately.


For a full description of the latest version of Hipchat Data Center,
see the release notes found at
https://confluence.atlassian.com/hc/hipchat-server-release-notes-608731400.html.
You can download the latest version of Hipchat Data Center from the
download centre found at https://www.hipchat.com/server/get-it.

For a full description of the latest version of Hipchat Server, see
the release notes found at
https://confluence.atlassian.com/hipchatdc3/hipchat-data-center-release-notes-909770898.html.
You can download the latest version of Hipchat Server from the
download centre found at https://www.hipchat.com/server/get-it.


Support:
If you have questions or concerns regarding this advisory, please raise a
support request at https://support.atlassian.com/.
-----BEGIN PGP SIGNATURE-----

iQIcBAEBCAAGBQJaF5X1AAoJECQgl6K8UnagVl8P/j3ZPwz52nZjD+GJWnzO+AC4
Ze+rFIsdemf7midAue+aT4KctKnR324HBmVy1JcBR+cnlLljrcpg/FTYC0vBFod6
X9w4llB2rPC3MoHyGESFhlFq5FiBAkAqtUfQCdToewcSrXWw8vyql3z69GwzXUTu
H+mTLA0akl4UlJDjNejQrju8aNTj4iDiRGOQ9XCIT3J23MZd8oB8EiRV6gi9oISD
jc/uTVgLAANyvWdb9ysz1Es8FU8CmB9hUrDwWQ42JoTuTrATCx395GjdjBC0EG0y
Mj8udYlErltjk4iY+CF57vPiOMUa5OfCrnfS1Cuu3vxef3AcNBtiH3LOyCAvgC61
91jUZrcNJKkpg+AGDosDbvQeU2G+FnbJK5HxTjUeH4Odk71/tQ6WzERQrMUxJmq6
zIrfuvqU69uE0qcTg5ENUTbGaWQ/BH+zoNsIruQlLAEb+Q1R5NhBndejK63h1Jaz
nbtksEx3iFnJ0iZElpKFsIHmCC/uKZTUjyoW1Kh0CAVLacfpjJ+TlqvXWvW5OPzy
3PEfVHr1B2v/htca2T09f534JUs/VzVnPA38mrmu0jWpbt1KjXGA68+yYektN+Nt
AlJEKGgYeK5TjEQigl95liCXbcUHudIuk7AlvFTAJ56UAy13wl8DLCUmv0Uho2Gv
7ICWuPgqhV6bKzr35tqF
=+eIB
-----END PGP SIGNATURE-----

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux - Powered by OpenVZ