lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 16 Dec 2006 06:59:07 -0500 (EST)
From:	"Robert P. J. Day" <rpjday@...dspring.com>
To:	Tim Schmielau <tim@...sik3.uni-rostock.de>
cc:	Jan Engelhardt <jengelh@...ux01.gwdg.de>,
	Stefan Richter <stefanr@...6.in-berlin.de>,
	Zach Brown <zach.brown@...cle.com>,
	Linux kernel mailing list <linux-kernel@...r.kernel.org>
Subject: Re: lots of code could be simplified by using ARRAY_SIZE()

On Fri, 15 Dec 2006, Tim Schmielau wrote:

> On Fri, 15 Dec 2006, Robert P. J. Day wrote:
> > On Fri, 15 Dec 2006, Jan Engelhardt wrote:
> > > Even  sizeof a / sizeof *a
> > >
> > > may happen.
> >
> > yes, sadly, there are a number of those as well.  back to the drawing
> > board.
>
> It might be interesting to grep for anything that divides two
> sizeofs and eyeball the result for possible mistakes. This would
> provide some real benefit beyond the cosmetical changes.

i did that a while ago and it's amazing the variation that you find
beyond the obvious:

$ grep -Er "sizeof.*/.*sizeof" . | less

...
./net/key/af_key.c:     sa->sadb_sa_len = sizeof(struct sadb_sa)/sizeof(uint64_t);
./net/xfrm/xfrm_policy.c:       int len = sizeof(struct xfrm_selector) / sizeof(u32);
./net/core/flow.c:      const int n_elem = sizeof(struct flowi) / sizeof(flow_compare_t);
./net/ipv4/netfilter/arp_tables.c:      for (i = 0; i < sizeof(*arp)/sizeof(__u32); i++)
./net/ipv4/af_inet.c:#define INETSW_ARRAY_LEN (sizeof(inetsw_array) / sizeof(struct inet_protosw))
./drivers/net/wireless/ray_cs.c:        .num_standard   = sizeof(ray_handler)/sizeof(iw_handler),

and on and on.  there's no way a cute little perl script is
going to clean up all of *that*.

so what to do?

rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ