lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 13 Feb 2007 15:19:00 +1100
From:	Nick Piggin <nickpiggin@...oo.com.au>
To:	Joe Perches <joe@...ches.com>
CC:	Ben Nizette <ben.nizette@...et.net.au>,
	linux-kernel@...r.kernel.org
Subject: Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)"
 to "array_for_each(index, array)"

Joe Perches wrote:
> On Tue, 2007-02-13 at 11:20 +1100, Ben Nizette wrote:
> 
>>  #define array_for_each(element, array) \
>>	for (int __idx = 0; __idx < ARRAY_SIZE((array)); \
>>		__idx++, (element) = &(array[__idx]))
> 
> 
> This requires all interior loop code be changed.

Ben is right though. Making this thing confusing to use is going
to be worse than sticking with the very simple and unconfusing
loops.

If you really wanted to introduce your loop, then please call it
array_for_each_idx, or something to distinguish it.

-- 
SUSE Labs, Novell Inc.
Send instant messages to your online friends http://au.messenger.yahoo.com 
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ