lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 23 May 2007 20:35:50 -0400
From:	"Josef 'Jeff' Sipek" <jsipek@...sunysb.edu>
To:	linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org
Cc:	akpm@...ux-foundation.org
Subject: [GIT PULL -mm] Unionfs cleanups and fixes

The following patches consist of mostly cleanups of the Unionfs code, as
well as fixes for several harder to hit bugs (resource/memory leaks).

As before, there is a git repo at:

git://git.kernel.org/pub/scm/linux/kernel/git/jsipek/unionfs.git

(master.kernel.org:/pub/scm/linux/kernel/git/jsipek/unionfs.git)

There are 21 new commits:

	Unionfs: Correctly decrement refcounts of mnt's upon branch management
	Unionfs: Removed a trailing whitespace
	Unionfs: Actually catch bad use of unionfs_mnt{get,put}
	Unionfs: Remove defunct unionfs_put_inode super op
	Unionfs: Documentation update regarding overlapping branches and new lookup code
	Unionfs: Disallow setting leftmost branch to readonly
	Unionfs: Use krealloc instead of open-coding the functionality
	Unionfs: Call realloc unconditionally
	Unionfs: Don't leak resources when copyup fails partially
	Unionfs: Prefix external functions with 'extern' properly
	Unionfs: Combine unionfs_write with __unionfs_write.
	Unionfs: Move unionfs_query_file to commonfops.c
	Unionfs: Rename our "do_rename" to __unionfs_rename
	Unionfs: Rename Unionfs's double_lock_dentry to avoid confusion
	Unionfs: Consistent pointer declaration spacing
	Unionfs: Added numerous comments
	Unionfs: Cleanup of strings and comments
	Unionfs: Add missing copyright notices
	Unionfs: Every printk should prefix with "unionfs: " consistently
	Unionfs: Coding style fixes
	Unionfs: Tiny documentation fixups

Thanks,

Josef 'Jeff' Sipek <jsipek@...sunysb.edu>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists