lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 05 Jan 2009 13:08:06 -0600
From:	James Bottomley <James.Bottomley@...senPartnership.com>
To:	Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
Cc:	Jens Axboe <jens.axboe@...cle.com>, linux-kernel@...r.kernel.org,
	linux-ide@...r.kernel.org, Alan Cox <alan@...rguk.ukuu.org.uk>
Subject: Re: [PATCH] block: export SSD/non-rotational queue flag through
	sysfs

On Mon, 2009-01-05 at 20:02 +0100, Bartlomiej Zolnierkiewicz wrote:
> On Monday 05 January 2009, Jens Axboe wrote:
> > On Mon, Jan 05 2009, Bartlomiej Zolnierkiewicz wrote:
> > > From: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
> > > Subject: [PATCH] block: export SSD/non-rotational queue flag through sysfs
> > > 
> > > For some devices (i.e. CFA ATA) we can't reliably detect whether
> > > the device is of rotational or non-rotational type so we need to
> > > leave the final decision about this setting to the user-space.
> > 
> > I agree with that, was actually planning on doing that myself.
> > 
> > > @@ -146,8 +167,8 @@ static ssize_t queue_nomerges_store(stru
> > >  		queue_flag_set(QUEUE_FLAG_NOMERGES, q);
> > >  	else
> > >  		queue_flag_clear(QUEUE_FLAG_NOMERGES, q);
> > > -
> > >  	spin_unlock_irq(q->queue_lock);
> > > +
> > >  	return ret;
> > >  }
> > >  
> > 
> > Hmm?
> 
> This is just a "bonus". :)
> 
> > > @@ -210,6 +231,12 @@ static struct queue_sysfs_entry queue_hw
> > >  	.show = queue_hw_sector_size_show,
> > >  };
> > >  
> > > +static struct queue_sysfs_entry queue_nonrot_entry = {
> > > +	.attr = {.name = "nonrot", .mode = S_IRUGO | S_IWUSR },
> > > +	.show = queue_nonrot_show,
> > > +	.store = queue_nonrot_store,
> > > +};
> > > +
> > 
> > Lets please use a better name for export reasons, non-rotational is a
> > lot better. Nobody will know what nonrot means :-)
> 
> Yeah...
> 
> From: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
> Subject: [PATCH v2] block: export SSD/non-rotational queue flag through sysfs
> 
> For some devices (i.e. CFA ATA) we can't reliably detect whether
> the device is of rotational or non-rotational type so we need to
> leave the final decision about this setting to the user-space.
> 
> As a bonus do a minor CodingStyle fixup in queue_nomerges_store().
> 
> Suggested-by: Alan Cox <alan@...rguk.ukuu.org.uk>
> Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
> ---
>  block/blk-sysfs.c |   30 +++++++++++++++++++++++++++++-
>  1 file changed, 29 insertions(+), 1 deletion(-)
> 
> Index: b/block/blk-sysfs.c
> ===================================================================
> --- a/block/blk-sysfs.c
> +++ b/block/blk-sysfs.c
> @@ -130,6 +130,27 @@ static ssize_t queue_max_hw_sectors_show
>  	return queue_var_show(max_hw_sectors_kb, (page));
>  }
>  
> +static ssize_t queue_nonrot_show(struct request_queue *q, char *page)
> +{
> +	return queue_var_show(blk_queue_nonrot(q), page);
> +}
> +
> +static ssize_t queue_nonrot_store(struct request_queue *q, const char *page,
> +				  size_t count)
> +{
> +	unsigned long nm;
> +	ssize_t ret = queue_var_store(&nm, page, count);
> +
> +	spin_lock_irq(q->queue_lock);
> +	if (nm)
> +		queue_flag_set(QUEUE_FLAG_NONROT, q);
> +	else
> +		queue_flag_clear(QUEUE_FLAG_NONROT, q);
> +	spin_unlock_irq(q->queue_lock);
> +
> +	return ret;
> +}
> +
>  static ssize_t queue_nomerges_show(struct request_queue *q, char *page)
>  {
>  	return queue_var_show(blk_queue_nomerges(q), page);
> @@ -146,8 +167,8 @@ static ssize_t queue_nomerges_store(stru
>  		queue_flag_set(QUEUE_FLAG_NOMERGES, q);
>  	else
>  		queue_flag_clear(QUEUE_FLAG_NOMERGES, q);
> -
>  	spin_unlock_irq(q->queue_lock);
> +
>  	return ret;
>  }
>  
> @@ -210,6 +231,12 @@ static struct queue_sysfs_entry queue_hw
>  	.show = queue_hw_sector_size_show,
>  };
>  
> +static struct queue_sysfs_entry queue_nonrot_entry = {
> +	.attr = {.name = "non-rotational", .mode = S_IRUGO | S_IWUSR },
> +	.show = queue_nonrot_show,
> +	.store = queue_nonrot_store,
> +};
> +
>  static struct queue_sysfs_entry queue_nomerges_entry = {
>  	.attr = {.name = "nomerges", .mode = S_IRUGO | S_IWUSR },
>  	.show = queue_nomerges_show,
> @@ -229,6 +256,7 @@ static struct attribute *default_attrs[]
>  	&queue_max_sectors_entry.attr,
>  	&queue_iosched_entry.attr,
>  	&queue_hw_sector_size_entry.attr,
> +	&queue_nonrot_entry.attr,
>  	&queue_nomerges_entry.attr,
>  	&queue_rq_affinity_entry.attr,
>  	NULL,

Almost all block devices might find this useful.  Ought not this flag to
be in the block layer appearing under /sys/block/<dev>?

James


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ