lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 18 Jan 2009 09:36:37 +0100
From:	Ingo Molnar <mingo@...e.hu>
To:	Tejun Heo <tj@...nel.org>
Cc:	Brian Gerst <brgerst@...il.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 03/17] x86-64: Convert irqstacks to per-cpu


* Tejun Heo <tj@...nel.org> wrote:

> Hello,
> 
> Brian Gerst wrote:
> >> Also, as pda field name, irqstackptr might be fine but wouldn't it be
> >> better to rename it to at least irq_stack_ptr as this change requires
> >> touching every users anyway?
> > 
> > I kept the same name unless it would conflict with something.  If you
> > want to rename it, it should be a separate patch.
> 
> Sure, that's an option too but it might as well be done when making 
> those percpu variables.  I don't really see why those two changes should 
> be separate.  There isn't any reason why they shouldn't be separate 
> either but if you're already mucking around every user...

yes, we should do the rename in this same patch as both patches have no 
impact on the actual kernel image. (sans source code line and string 
related deltas in the image.) Feel free to do the rename in his patch - 
that's the fastest way.

I'd suggest to rename from:

  DECLARE_PER_CPU(char, irqstack[IRQSTACKSIZE]);
  DECLARE_PER_CPU(char *, irqstackptr);

to:

  DECLARE_PER_CPU(char, irq_stack[IRQSTACKSIZE]);
  DECLARE_PER_CPU(char *, irq_stack_ptr);

In other cases, lets get Brian's patches in without further latencies so 
that we drain his pending-patches pipeline and get a consolidated base 
everyone can work from. Brian already had an unfortunate (and 
time-consuming) rebase/conflict-resolution pass due to us moving the 
percpu code from under him. We can do non-critical followups in separate 
delta patches.

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ