lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 19 Jan 2009 09:05:24 +0100
From:	Stefan Richter <stefanr@...6.in-berlin.de>
To:	righi.andrea@...il.com
CC:	Johannes Weiner <hannes@...xchg.org>,
	Dave Jones <davej@...hat.com>,
	Johannes Weiner <hannes@...urebad.de>,
	Krzysztof Helt <krzysztof.h1@...pl>,
	Andrew Morton <akpm@...ux-foundation.org>,
	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] fbmem: fix copy_from/to_user() with mutex held

Stefan Richter wrote:
> Andrea Righi wrote:
>> +struct fb_info *get_fb_info(struct fb_info *info)
>> +__acquires(&info->lock)
>> +{
>> +	mutex_lock(&info->lock);
>> +	if (!info->fbops) {
>> +		mutex_unlock(&info->lock);
>> +		return NULL;
>> +	}
>> +	return info;
>> +}
>> +
>> +void put_fb_info(struct fb_info *info)
>> +__releases(&info->lock)
>> +{
>> +	mutex_unlock(&info->lock);
>> +}
>> +
> 
> These are IMO bad function names.

PS:  The return value of the mutex_lock wrapper is also bad.  A bool or
int would IMO be clearer, similar to the return value of mutex_trylock.
-- 
Stefan Richter
-=====-==--= ---= =--==
http://arcgraph.de/sr/
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ