lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 20 Mar 2009 09:27:12 +0100
From:	Ingo Molnar <mingo@...e.hu>
To:	David Rientjes <rientjes@...gle.com>
Cc:	Andrew Morton <akpm@...ux-foundation.org>,
	linux-kernel@...r.kernel.org
Subject: Re: [patch] vmscan: print shrink_slab symbol name on negative
	shrinker objects


* David Rientjes <rientjes@...gle.com> wrote:

> When a shrinker has a negative number of objects to delete, the symbol
> name of the shrinker should be printed, not shrink_slab.
> 
> Signed-off-by: David Rientjes <rientjes@...gle.com>
> ---
>  mm/vmscan.c |    9 +++++++--
>  1 files changed, 7 insertions(+), 2 deletions(-)
> 
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -40,6 +40,7 @@
>  #include <linux/memcontrol.h>
>  #include <linux/delayacct.h>
>  #include <linux/sysctl.h>
> +#include <linux/kallsyms.h>
>  
>  #include <asm/tlbflush.h>
>  #include <asm/div64.h>
> @@ -214,8 +215,12 @@ unsigned long shrink_slab(unsigned long scanned, gfp_t gfp_mask,
>  		do_div(delta, lru_pages + 1);
>  		shrinker->nr += delta;
>  		if (shrinker->nr < 0) {
> -			printk(KERN_ERR "%s: nr=%ld\n",
> -					__func__, shrinker->nr);
> +			char symname[KSYM_NAME_LEN];
> +
> +			if (lookup_symbol_name((unsigned long)shrinker->shrink,
> +					       symname) > 0)
> +				printk(KERN_ERR "shrink_slab: %s nr=%ld\n",
> +				       symname, shrinker->nr);
>  			shrinker->nr = max_pass;

Please dont open-code lookup_symbol_name() for function pointers - 
we have %pF for such purposes.

Btw., probably all existing print_symbol() uses in mm/*.c should be 
converted to %pF:

mm/memory.c:		print_symbol(KERN_ALERT "vma->vm_ops->fault: %s\n",
mm/memory.c:		print_symbol(KERN_ALERT "vma->vm_file->f_op->mmap: %s\n",
mm/slab.c:		print_symbol("(%s)",
mm/slub.c:			len += sprint_symbol(buf + len, (unsigned long)l->addr);
mm/slub.c:		int n = sprint_symbol(buf, (unsigned long)s->ctor);
mm/vmalloc.c:		sprint_symbol(buff, (unsigned long)v->caller);

[ Except the second slub.c one which should be %pS ]

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ