lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 04 Apr 2009 21:32:27 +0200
From:	Krzysztof Halasa <khc@...waw.pl>
To:	David Brownell <david-b@...bell.net>
Cc:	lkml <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] fix RTC-CMOS message, now with SOB

David Brownell <david-b@...bell.net> writes:

>> +               !is_valid_irq(rtc_irq) ? "no alarms" :
>> +               cmos_rtc.mon_alrm ? "alarms up to one year" :
>> +               cmos_rtc.day_alrm ? "alarms up to one month" :
>> +               "alarms up to one day",
>
> Could you reformat that so it looks more like the compound-IF
> statement it really is?  That is, display the nesting structure.

You mean something like

>> +               !is_valid_irq(rtc_irq) ? "no alarms" :
>> +                       cmos_rtc.mon_alrm ? "alarms up to one year" :
>> +                       cmos_rtc.day_alrm ? "alarms up to one month" :
>> +                       "alarms up to one day",

Not this certainly?

>> +               !is_valid_irq(rtc_irq) ? "no alarms" :
>> +                       cmos_rtc.mon_alrm ? "alarms up to one year" :
>> +                               cmos_rtc.day_alrm ? "alarms up to one month" :
>> +                                       "alarms up to one day",

> And not use negative logic for that first test.

I think it's worse WRT readability:

+		is_valid_irq(rtc_irq) ?
+		        (cmos_rtc.mon_alrm ? "alarms up to one year" :
+		                cmos_rtc.day_alrm ? "alarms up to one month" :
+		                        "alarms up to one day") :
+		        "no alarms";

Feel free to use the following or your own version as long as the
resulting message is correct.
Thanks.

Signed-off-by: Krzysztof Hałasa <khc@...waw.pl>

--- a/drivers/rtc/rtc-cmos.c
+++ b/drivers/rtc/rtc-cmos.c
@@ -794,17 +794,15 @@ cmos_do_probe(struct device *dev, struct resource *ports, int rtc_irq)
 		goto cleanup2;
 	}
 
-	pr_info("%s: alarms up to one %s%s, %zd bytes nvram%s\n",
-			cmos_rtc.rtc->dev.bus_id,
-			is_valid_irq(rtc_irq)
-				?  (cmos_rtc.mon_alrm
-					? "year"
-					: (cmos_rtc.day_alrm
-						? "month" : "day"))
-				: "no",
-			cmos_rtc.century ? ", y3k" : "",
-			nvram.size,
-			is_hpet_enabled() ? ", hpet irqs" : "");
+	pr_info("%s: %s%s, %zd bytes nvram%s\n",
+		cmos_rtc.rtc->dev.bus_id,
+		!is_valid_irq(rtc_irq) ? "no alarms" :
+			cmos_rtc.mon_alrm ? "alarms up to one year" :
+			cmos_rtc.day_alrm ? "alarms up to one month" :
+			"alarms up to one day",
+		cmos_rtc.century ? ", y3k" : "",
+		nvram.size,
+		is_hpet_enabled() ? ", hpet irqs" : "");
 
 	return 0;
 
-- 
Krzysztof Halasa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ