lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 14 May 2009 20:38:26 +0800
From:	Ming Lei <tom.leiming@...il.com>
To:	Dave Young <hidave.darkstar@...il.com>
Cc:	Greg KH <gregkh@...e.de>,
	Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/3] kobject : kobject_set_name_vargs leak fix

2009/5/14 Dave Young <hidave.darkstar@...il.com>:
> On Mon, May 11, 2009 at 2:16 PM, Dave Young <hidave.darkstar@...il.com> wrote:
>> kobject_set_name_vargs will leak the old_name when return -ENOMEM,
>> move the kfree(old_name) before the return path.
>
> Hi, greg
>
> I rethought about this problem, does such issue exist really? I means
> that kobject->name != NULL scenario.
>
> there's following comments of this function:
>
>  * This sets the name of the kobject.  If you have already added the
>  * kobject to the system, you must call kobject_rename() in order to
>  * change the name of the kobject
>
> So what if something like :
>
> if (kobject->name) {
>  WARN(1, KERN_WARNING, "there's name for kobject already!");
>  return -EINVAL;
> }
>
> if (!fmt)
>  return 0;
>
>>
>> Signed-off-by: Dave Young <hidave.darkstar@...il.com>
>> ---
>> lib/kobject.c |    2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff -uprN linux.old/lib/kobject.c linux.new/lib/kobject.c
>> --- linux.old/lib/kobject.c     2009-05-11 13:59:01.000000000 +0800
>> +++ linux.new/lib/kobject.c     2009-05-11 13:59:34.000000000 +0800
>> @@ -221,6 +221,7 @@ int kobject_set_name_vargs(struct kobjec
>>        if (kobj->name && !fmt)
>>                return 0;
>>
>> +       kfree(old_name);
>>        kobj->name = kvasprintf(GFP_KERNEL, fmt, vargs);
>>        if (!kobj->name)
>>                return -ENOMEM;

IMO, Greg means it is better that the fix should be :
        if (!kobj->name) {
                kobj->name = old_name;
                return -ENOMEM;
        }

Right?

>> @@ -229,7 +230,6 @@ int kobject_set_name_vargs(struct kobjec
>>        while ((s = strchr(kobj->name, '/')))
>>                s[0] = '!';
>>
>> -       kfree(old_name);
>>        return 0;
>>  }
>>
>
>
>
> --
> Regards
> dave
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
>



-- 
Lei Ming
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ