lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 06 Jul 2009 17:12:14 +0800
From:	Amerigo Wang <amwang@...hat.com>
To:	Tao Ma <tao.ma@...cle.com>
CC:	linux-kernel@...r.kernel.org, Jeff Mahoney <jeffm@...e.com>,
	Yan Zheng <zheng.yan@...cle.com>,
	Josef Bacik <jbacik@...hat.com>, Arjan <arjan@...radead.org>,
	Chris Mason <chris.mason@...cle.com>,
	akpm@...ux-foundation.org, linux-btrfs@...r.kernel.org,
	Sven Wegener <sven.wegener@...aler.net>
Subject: Re: [Patch v2] btrfs: use file_remove_suid() after i_mutex is held

Tao Ma wrote:
> Hi Amerigo,
>
> Amerigo Wang wrote:
>> V1 -> V2:
>> Move kmalloc() before mutex_lock(), suggested by Arjan.
>>
>> file_remove_suid() should be called with i_mutex held,
>> file_update_time() too. So move them after mutex_lock().
>>
>> Plus, check the return value of kmalloc().
>>
>> Signed-off-by: WANG Cong <amwang@...hat.com>
>> Cc: Arjan <arjan@...radead.org>
>> Cc: Chris Mason <chris.mason@...cle.com>
>> Cc: Yan Zheng <zheng.yan@...cle.com>
>> Cc: Sven Wegener <sven.wegener@...aler.net>
>> Cc: Josef Bacik <jbacik@...hat.com>
>> Cc: Jeff Mahoney <jeffm@...e.com>
>>
>> ---
>> diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
>> index 7c3cd24..09ef5d6 100644
>> --- a/fs/btrfs/file.c
>> +++ b/fs/btrfs/file.c
>> @@ -944,14 +944,17 @@ static ssize_t btrfs_file_write(struct file 
>> *file, const char __user *buf,
>>      if (count == 0)
>>          goto out_nolock;
>>  
>> +    pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
>> +    if (!pages)
>> +        goto out_nolock;
> I guess you need to set err to -ENOMEM here so that the caller knows 
> what's wrong. With your patch, this function just return 0(since 
> num_written and err are both 0) with no error, and I guess it is worse 
> than kernel BUG out when the NULL pages is used later.

Agree. Thanks, I will update it.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ