lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 29 Oct 2009 08:57:35 +0100
From:	Ingo Molnar <mingo@...e.hu>
To:	Li Zefan <lizf@...fujitsu.com>,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	Andrew Morton <akpm@...ux-foundation.org>
Cc:	Steven Rostedt <rostedt@...dmis.org>,
	Frederic Weisbecker <fweisbec@...il.com>,
	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] tracing: Fix to use unused attribute


* Li Zefan <lizf@...fujitsu.com> wrote:

> ____ftrace_check_##name() is used for compile-time check
> on F_printk() only, so it should be marked as __unused
> instead of __used.
> 
> Signed-off-by: Li Zefan <lizf@...fujitsu.com>
> ---
> 
> I'm thinking about introducing __always_unused, comparing
> to __maybe_unused.
> 
> ---
>  kernel/trace/trace_export.c |    5 +++--
>  1 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/kernel/trace/trace_export.c b/kernel/trace/trace_export.c
> index 934d81f..85309fc 100644
> --- a/kernel/trace/trace_export.c
> +++ b/kernel/trace/trace_export.c
> @@ -48,11 +48,12 @@
>  struct ____ftrace_##name {					\
>  	tstruct							\
>  };								\
> -static void __used ____ftrace_check_##name(void)		\
> +static void __attribute__((unused))				\
> +____ftrace_check_##name(void)					\
>  {								\
>  	struct ____ftrace_##name *__entry = NULL;		\
>  								\
> -	/* force cmpile-time check on F_printk() */		\
> +	/* force compile-time check on F_printk() */		\
>  	printk(print);						\
>  }

Hm, open-coding __attribute__()'s is not good.

These tags are somewhat of a mess:

 #if __GNUC_MINOR__ >= 3
 # define __used                 __attribute__((__used__))
 #else
 # define __used                 __attribute__((__unused__))
 #endif

I've Cc:-ed Linus and Andrew, to solicite feedback on __always_unused. I 
think we should add it.

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ