lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 31 Dec 2009 00:55:37 +0100
From:	Arnd Bergmann <arnd@...db.de>
To:	Jiri Slaby <jslaby@...ell.com>
Cc:	jirislaby@...il.com, mingo@...e.hu, nhorman@...driver.com,
	sfr@...b.auug.org.au, linux-kernel@...r.kernel.org,
	akpm@...ux-foundation.org, marcin.slusarz@...il.com,
	tglx@...utronix.de, mingo@...hat.com, hpa@...or.com,
	torvalds@...ux-foundation.org, James Morris <jmorris@...ei.org>,
	Heiko Carstens <heiko.carstens@...ibm.com>
Subject: Re: [PATCH 15/16] COMPAT: add get/put_compat_rlimit

On Wednesday 18 November 2009, Jiri Slaby wrote:
> @@ -284,17 +317,12 @@ asmlinkage long compat_sys_setrlimit(unsigned int resource,
>         if (resource >= RLIM_NLIMITS)
>                 return -EINVAL;
>  
> -       if (!access_ok(VERIFY_READ, rlim, sizeof(*rlim)) ||
> -           __get_user(r.rlim_cur, &rlim->rlim_cur) ||
> -           __get_user(r.rlim_max, &rlim->rlim_max))
> -               return -EFAULT;
> +       ret = get_compat_rlimit(&r, rlim);
> +       if (ret)
> +               return ret;
>  
> -       if (r.rlim_cur == COMPAT_RLIM_INFINITY)
> -               r.rlim_cur = RLIM_INFINITY;
> -       if (r.rlim_max == COMPAT_RLIM_INFINITY)
> -               r.rlim_max = RLIM_INFINITY;
>         set_fs(KERNEL_DS);
> -       ret = sys_setrlimit(resource, (struct rlimit __user *) &r);
> +       ret = sys_setrlimit(resource, (struct rlimit __force __user *)&r);
>         set_fs(old_fs);
>         return ret;

Since you are already rewriting the whole function here, it would be
nice if you could just call do_setrlimit() with the kernel pointer
instead of the set_fs() and __force tricks. For getrlimit, it may
be easier to just open-code the whole function, and for your new
functions, you could pass the pid into do_setrlimit instead of the
task in order to reduce code duplication between compat_sys_setprlimit
and sys_setprlimit.
If you interpret a pid argument of zero as 'current', we can deprecate
the kernel implementation of setrlimit and getrlimit for future
architecture ports.

Yes, I realize my reply is late in this thread, but I assume your patch
is still current since it hasn't made it into 2.6.33.

	Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ