lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 12 Jul 2010 10:55:49 +0800
From:	Xiao Guangrong <xiaoguangrong@...fujitsu.com>
To:	Avi Kivity <avi@...hat.com>
CC:	Marcelo Tosatti <mtosatti@...hat.com>,
	LKML <linux-kernel@...r.kernel.org>,
	KVM list <kvm@...r.kernel.org>
Subject: Re: [PATCH v5 5/9] KVM: MMU: introduce gfn_to_page_many_atomic()
 function



Avi Kivity wrote:
> On 07/06/2010 01:48 PM, Xiao Guangrong wrote:
>> This function not only return the gfn's page but also the page number
>> after @gfn in the slot
>>
>>
>> @@ -923,15 +923,25 @@ static unsigned long gfn_to_hva_memslot(struct
>> kvm_memory_slot *slot, gfn_t gfn)
>>       return slot->userspace_addr + (gfn - slot->base_gfn) * PAGE_SIZE;
>>   }
>>
>> -unsigned long gfn_to_hva(struct kvm *kvm, gfn_t gfn)
>> +static unsigned long gfn_to_hva_many(struct kvm *kvm, gfn_t gfn, int
>> *entry)
>>   {
>>    
> 
> 'entry' better be gfn_t.  We limit gfns in a slot, but that's
> artificial, let's use the correct type.
> 
> Also suggest nr_pages as the name.
> 

OK, will fix it in the next version.

>> @@ -1011,6 +1021,23 @@ pfn_t gfn_to_pfn_memslot(struct kvm *kvm,
>>       return hva_to_pfn(kvm, addr, false);
>>   }
>>
>> +int gfn_to_page_many_atomic(struct kvm *kvm, gfn_t gfn,
>> +                struct page **pages, int nr_pages, bool *enough)
>> +{
>> +    unsigned long addr;
>> +    int entry, ret;
>> +
>> +    addr = gfn_to_hva_many(kvm, gfn,&entry);
>> +    if (kvm_is_error_hva(addr))
>> +        return -1;
>> +
>> +    entry = min(entry, nr_pages);
>> +    *enough = (entry == nr_pages) ? true : false;
>>    
> 
> s/ ? true : false//; :)

Yeah, it's better.

> 
> Why not return 0 if !enough?
> 

I think it's better that handle the reset pages in the slot, for example,
we expect 16 pages are consecutive, but only 12 pages in the slot, the better
way is handle the reset 12 pages not throw those away.

>> +    ret = __get_user_pages_fast(addr, entry, 1, pages);
>> +    return ret;
>> +}
>> +EXPORT_SYMBOL_GPL(gfn_to_page_many_atomic);
>> +
>>   struct page *gfn_to_page(struct kvm *kvm, gfn_t gfn)
>>   {
>>       pfn_t pfn;
>>    
> 
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ