lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 12 Jul 2010 21:17:29 -0700 (PDT)
From:	David Miller <davem@...emloft.net>
To:	dilinger@...ued.net
Cc:	grant.likely@...retlab.ca, devicetree-discuss@...ts.ozlabs.org,
	sparclinux@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] sparc: move is_root_node from private header to of.h

From: Andres Salomon <dilinger@...ued.net>
Date: Tue, 13 Jul 2010 20:05:41 +0000

> On Mon, 12 Jul 2010 09:53:04 -0600
> Grant Likely <grant.likely@...retlab.ca> wrote:
> 
>> On Tue, Jul 13, 2010 at 3:42 AM, Andres Salomon <dilinger@...ued.net>
>> wrote:
>> >
>> > Make is_root_node available for all archs to use, as it's not
>> > PROM-specific. Also rename it to of_is_root_node, and a few other
>> > minor changes for style/consistency.
>> >
>> > Signed-off-by: Andres Salomon <dilinger@...ued.net>
>> > ---
>> >  arch/sparc/kernel/prom.h        |    8 --------
>> >  arch/sparc/kernel/prom_64.c     |    6 +++---
>> >  arch/sparc/kernel/prom_common.c |    2 +-
>> >  include/linux/of.h              |    8 ++++++++
>> >  4 files changed, 12 insertions(+), 12 deletions(-)
>> [...]
>> > diff --git a/include/linux/of.h b/include/linux/of.h
>> > index a367e19..b38cdf7 100644
>> > --- a/include/linux/of.h
>> > +++ b/include/linux/of.h
>> > @@ -97,6 +97,14 @@ extern struct device_node *of_node_get(struct
>> > device_node *node); extern void of_node_put(struct device_node
>> > *node); #endif
>> >
>> > +static inline bool of_is_root_node(const struct device_node *node)
>> > +{
>> > +       if (!node)
>> > +               return false;
>> > +
>> > +       return (node->parent == NULL);
>> > +}
>> 
>> Are you okay if I shorten this to?
>> 
>> +static inline bool of_is_root_node(const struct device_node *node)
>> +{
>> +       return (node && (node->parent == NULL));
>> +}
>> 
>> g.
> 
> It's fine with me.
> 

Me too:

Acked-by: David S. Miller <davem@...emloft.net>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ