lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 29 Sep 2010 18:37:00 -0700
From:	Greg KH <greg@...ah.com>
To:	David Cross <david.cross@...ress.com>
Cc:	linux-kernel@...r.kernel.org
Subject: Re: Staging: west bridge, cyasgadget fix for
	usb_gadget_probe_driver

On Thu, Sep 23, 2010 at 05:20:00PM -0700, David Cross wrote:
> This patch fixes the west bridge cyasgadget driver in order to allow for
> compilation against the linux-next tree. This changes
> usb_gadget_register_driver to usb_gadget_probe_driver and updates this
> function based on the new function definition (bind call).
> 
> Signed-off-by: David Cross <david.cross@...ress.com>
> 
> --- linux-next-vanilla/drivers/staging/westbridge/astoria/gadget/cyasgadget.c	2010-09-20 23:40:58.000000000 -0700
> +++ linux-next-incremen/drivers/staging/westbridge/astoria/gadget/cyasgadget.c	2010-09-23 16:54:32.000000000 -0700
> @@ -1882,9 +1882,8 @@ static void cyas_ep0_start(
>   * disconnect is reported.  then a host may connect again, or
>   * the driver might get unbound.
>   */
> -int usb_gadget_register_driver(
> -				struct usb_gadget_driver *driver
> -				)
> +int usb_gadget_probe_driver(struct usb_gadget_driver *driver,
> +		int (*bind)(struct usb_gadget *))
>  {
>  	cyasgadget *dev = cy_as_gadget_controller ;
>  	int		retval;
> @@ -1898,7 +1897,7 @@ int usb_gadget_register_driver(
>  	* "must not be used in normal operation"
>  	*/
>  	if (!driver
> -		|| !driver->bind
> +		|| !bind
>  		|| !driver->unbind
>  		|| !driver->setup)
>  		return -EINVAL;
> @@ -1919,7 +1918,7 @@ int usb_gadget_register_driver(
>  	cyas_usb_reset(dev) ; /* External usb */
>  	cyas_usb_reinit(dev) ; /* Internal */
>  
> -	retval = driver->bind(&dev->gadget);
> +	retval = bind(&dev->gadget);
>  	if (retval) {
>  		#ifndef WESTBRIDGE_NDEBUG
>  		cy_as_hal_print_message("%s bind to driver %s --> %d\n",
> @@ -1938,7 +1937,7 @@ int usb_gadget_register_driver(
>  
>  	return 0;
>  }
> -EXPORT_SYMBOL(usb_gadget_register_driver);
> +EXPORT_SYMBOL(usb_gadget_probe_driver);

That's a pretty generic name you are exporting, I'd recommend changing
this very soon...

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists