lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 11 Jan 2011 09:24:04 -0800
From:	john stultz <johnstul@...ibm.com>
To:	Nicolas Pitre <nico@...xnic.net>,
	Thomas Gleixner <tglx@...utronix.de>
Cc:	lkml <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] clocks_calc_mult_shift(): rename minsec argument
 according to actual usage

On Tue, 2011-01-11 at 12:18 -0500, Nicolas Pitre wrote:
> The minsec argument to clocks_calc_mult_shift() is misnamed. It is used 
> to clamp the magnitude of the mult factor so that a multiplication with 
> any value in the given range won't overflow a 64 bit result.  Let's 
> rename it to match the actual usage.
> 
> Signed-off-by: Nicolas Pitre <nicolas.pitre@...aro.org>

Acked-by: John Stultz <johnstul@...ibm.com>

Thomas, mind picking this up for 2.6.38?

thanks
-john

> diff --git a/kernel/time/clocksource.c b/kernel/time/clocksource.c
> index c18d7ef..8588abc 100644
> --- a/kernel/time/clocksource.c
> +++ b/kernel/time/clocksource.c
> @@ -113,7 +113,7 @@ EXPORT_SYMBOL_GPL(timecounter_cyc2time);
>   * @shift:	pointer to shift variable
>   * @from:	frequency to convert from
>   * @to:		frequency to convert to
> - * @minsec:	guaranteed runtime conversion range in seconds
> + * @maxsec:	guaranteed runtime conversion range in seconds
>   *
>   * The function evaluates the shift/mult pair for the scaled math
>   * operations of clocksources and clockevents.
> @@ -122,7 +122,7 @@ EXPORT_SYMBOL_GPL(timecounter_cyc2time);
>   * NSEC_PER_SEC == 1GHz and @from is the counter frequency. For clock
>   * event @to is the counter frequency and @from is NSEC_PER_SEC.
>   *
> - * The @minsec conversion range argument controls the time frame in
> + * The @maxsec conversion range argument controls the time frame in
>   * seconds which must be covered by the runtime conversion with the
>   * calculated mult and shift factors. This guarantees that no 64bit
>   * overflow happens when the input value of the conversion is
> @@ -131,7 +131,7 @@ EXPORT_SYMBOL_GPL(timecounter_cyc2time);
>   * factors.
>   */
>  void
> -clocks_calc_mult_shift(u32 *mult, u32 *shift, u32 from, u32 to, u32 minsec)
> +clocks_calc_mult_shift(u32 *mult, u32 *shift, u32 from, u32 to, u32 maxsec)
>  {
>  	u64 tmp;
>  	u32 sft, sftacc= 32;
> @@ -140,7 +140,7 @@ clocks_calc_mult_shift(u32 *mult, u32 *shift, u32 from, u32 to, u32 minsec)
>  	 * Calculate the shift factor which is limiting the conversion
>  	 * range:
>  	 */
> -	tmp = ((u64)minsec * from) >> 32;
> +	tmp = ((u64)maxsec * from) >> 32;
>  	while (tmp) {
>  		tmp >>=1;
>  		sftacc--;


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ