lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 1 Feb 2011 21:31:21 -0700
From:	Grant Likely <grant.likely@...retlab.ca>
To:	Thomas Chou <thomas@...ron.com.tw>
Cc:	Dmitry Torokhov <dmitry.torokhov@...il.com>,
	linux-kernel@...r.kernel.org, nios2-dev@...c.et.ntust.edu.tw,
	linux-input@...r.kernel.org, devicetree-discuss@...ts.ozlabs.org,
	Walter Goossens <waltergoossens@...e.nl>
Subject: Re: [PATCH v2] altera_ps2: Add devicetree support

On Mon, Jan 24, 2011 at 01:58:13PM +0800, Thomas Chou wrote:
> From: Walter Goossens <waltergoossens@...e.nl>
> 
> Signed-off-by: Walter Goossens <waltergoossens@...e.nl>
> Signed-off-by: Thomas Chou <thomas@...ron.com.tw>
> ---
> v2 use const and add compat version.
> 
>  drivers/input/serio/altera_ps2.c |   11 +++++++++--
>  1 files changed, 9 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/input/serio/altera_ps2.c b/drivers/input/serio/altera_ps2.c
> index 7998560..63325ee 100644
> --- a/drivers/input/serio/altera_ps2.c
> +++ b/drivers/input/serio/altera_ps2.c
> @@ -19,6 +19,7 @@
>  #include <linux/platform_device.h>
>  #include <linux/io.h>
>  #include <linux/slab.h>
> +#include <linux/of.h>
>  
>  #define DRV_NAME "altera_ps2"
>  
> @@ -173,6 +174,12 @@ static int __devexit altera_ps2_remove(struct platform_device *pdev)
>  	return 0;
>  }
>  
> +static const struct of_device_id altera_ps2_match[] = {
> +	{ .compatible = "altr,ps2-1.0", },

I thought I had seen 'altera' instead of an abbreviation being used in
a previous patch.  I don't care much whether 'altr' or 'altera' is
used, but I'd like to know that there is consensus from the Altera
users so that all the drivers use the same prefix.

> +	{},
> +}
> +MODULE_DEVICE_TABLE(of, altera_ps2_match);
> +
>  /*
>   * Our device driver structure
>   */
> @@ -182,6 +189,7 @@ static struct platform_driver altera_ps2_driver = {
>  	.driver	= {
>  		.name	= DRV_NAME,
>  		.owner	= THIS_MODULE,
> +		.of_match_table = altera_ps2_match,

At the moment, this patch can only be applied against my
devicetree/next branch since there is a #ifdef CONFIG_OF around
of_match_table in mainline, and the patch to remove it is in my next
branch.  I'm okay with taking it through my tree if Dmitry agrees.

g.

>  	},
>  };
>  
> @@ -189,13 +197,12 @@ static int __init altera_ps2_init(void)
>  {
>  	return platform_driver_register(&altera_ps2_driver);
>  }
> +module_init(altera_ps2_init);
>  
>  static void __exit altera_ps2_exit(void)
>  {
>  	platform_driver_unregister(&altera_ps2_driver);
>  }
> -
> -module_init(altera_ps2_init);
>  module_exit(altera_ps2_exit);
>  
>  MODULE_DESCRIPTION("Altera University Program PS2 controller driver");
> -- 
> 1.7.3.4
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ