lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Wed, 2 Feb 2011 14:37:34 -0200
From:	"Gustavo F. Padovan" <padovan@...fusion.mobi>
To:	Rogério Brito <rbrito@....usp.br>
Cc:	linux-kernel@...r.kernel.org,
	Miguel Ojeda <miguel.ojeda.sandonis@...il.com>,
	Alexander Holler <holler@...oftware.de>
Subject: Re: [PATCH] ath3k: Avoid duplication of code

Hi Rogério,

* Rogério Brito <rbrito@....usp.br> [2011-01-28 20:18:10 -0200]:

> 
> Hi.
> 
> In commit 86e09287e4f8c81831b4d4118a48597565f0d21b, to reduce memory
> usage, the functions of the ath3k module were rewritten to release the
> firmware blob after it has been loaded (successfully or not).
> 
> The resuting code has some redundancy and the compiler can potentially
> produce better code if we omit a function call that is unconditionally
> executed in
> 
> ,----
> | 	if (ath3k_load_firmware(udev, firmware)) {
> | 		release_firmware(firmware);
> | 		return -EIO;
> |	}
> |	release_firmware(firmware);
> |
> |	return 0;
> | }
> `----
> 
> It may also be argued that the rewritten code becomes easier to read,
> and also to see the code coverage of the snippet in question.
> 
> 
> Signed-off-by: Rogério Brito <rbrito@....usp.br>
> Cc: Alexander Holler <holler@...oftware.de>
> Cc: "Gustavo F. Padovan" <padovan@...fusion.mobi>
> Cc: Miguel Ojeda <miguel.ojeda.sandonis@...il.com>

Please send me your patch in a 'git format-patch' way, so I can apply it
without having to edit the commit message. And add "Bluetooth:" to the
beginning of the commit title.

> 
> ---
> 
> Thanks for all the feedback on the previous patches. The one that didn't
> compile before was sent without a hunk. This time everything all the
> basics are verified.
> 
> 
> diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
> index a126e61..42fa531 100644
> --- a/drivers/bluetooth/ath3k.c
> +++ b/drivers/bluetooth/ath3k.c
> @@ -106,6 +106,7 @@ static int ath3k_probe(struct usb_interface *intf,
>  {
>  	const struct firmware *firmware;
>  	struct usb_device *udev = interface_to_usbdev(intf);
> +	int ret;
>  
>  	BT_DBG("intf %p id %p", intf, id);
>  
> @@ -116,13 +117,10 @@ static int ath3k_probe(struct usb_interface *intf,
>  		return -EIO;
>  	}
>  
> -	if (ath3k_load_firmware(udev, firmware)) {
> -		release_firmware(firmware);
> -		return -EIO;
> -	}
> +	ret = ath3k_load_firmware(udev, firmware);
>  	release_firmware(firmware);
>  
> -	return 0;
> +	return ret ? -EIO : 0;

just return ret;
It is enough.

Regards,

-- 
Gustavo F. Padovan
http://profusion.mobi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ