lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 7 Jun 2011 09:03:57 -0600
From:	Grant Likely <grant.likely@...retlab.ca>
To:	viresh kumar <viresh.kumar@...com>
Cc:	"jgarzik@...ox.com" <jgarzik@...ox.com>,
	"linux-ide@...r.kernel.org" <linux-ide@...r.kernel.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	Armando VISCONTI <armando.visconti@...com>,
	Shiraz HASHIM <shiraz.hashim@...com>, rsarmah@...liedmicro.com,
	Stephen Rothwell <sfr@...b.auug.org.au>
Subject: Re: drivers/ata/sata_dwc_460ex.c: Do we still need "struct
 of_device_id sata_dwc_match"

On Tue, Jun 07, 2011 at 04:23:07PM +0530, viresh kumar wrote:
> 
> Hello,
> 
> sata_dwc is also present on SPEAr SoC from ST, so i am removing dependency of this
> driver from 460ex and renaming it to sata_dwc.c.
> 
> While doing that, i saw following:
> 
> static const struct of_device_id sata_dwc_match[] = {
> 	{ .compatible = "amcc,sata-460ex", },
> 	{}
> };
> MODULE_DEVICE_TABLE(of, sata_dwc_match);
> 
> 
> I don't know if this is still useful or not with platform_device, as it was with
> of_platform_*.
> 
> Should i remove it completely? or should i just rewrite following as:
> 
> static const struct of_device_id sata_dwc_match[] = {
> 	{ .compatible = "amcc,sata_dwc", },
> 	{}
> };
> MODULE_DEVICE_TABLE(of, sata_dwc_match);

No, don't remove it and don't remove the "amcc,sata-460ex" string.
The compatible property is intended to identify the exact hardware,
and removing existing strings will break deployed boards.  However, it
is fine to add new strings to the match table.

> 
> For this i will also update: arch/powerpc/boot/dts/canyonlands.dts
> 
> 		SATA0: sata@...d1000 {
> 			compatible = "amcc,sata-460ex";
> 			reg = <4 0xbffd1000 0x800 4 0xbffd0800 0x400>;
> 			interrupt-parent = <&UIC3>;
> 			interrupts = <0x0 0x4       /* SATA */
> 				      0x5 0x4>;     /* AHBDMA */
> 		};
> 
> Thanks for your replies.
> 
> -- 
> viresh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ