lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 20 Jul 2011 11:43:11 -0600
From:	Jim Cromie <jim.cromie@...il.com>
To:	Joe Perches <joe@...ches.com>
Cc:	jbaron@...hat.com, linux-kernel@...r.kernel.org,
	bvanassche@....org, gregkh@...e.de, gnb@...h.org
Subject: Re: [PATCH 21/21] dynamic_debug: delete pending queries

On Mon, Jul 11, 2011 at 6:25 PM, Joe Perches <joe@...ches.com> wrote:
> On Mon, 2011-07-11 at 01:46 -0600, Jim Cromie wrote:
>> delete pending queries by re-issuing it with disabled flags
> []
>> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> []
>> @@ -505,7 +505,17 @@ static int ddebug_save_pending(struct ddebug_query *query,
>>
>>       list_for_each_entry_safe(pq, pqnext, &pending_queries, link) {
>>               if (queries_match(query, &pq->query)) {
>> -                     /* query already in list, update flags */
>> +                     /* query already in list */
>> +                     if (!flags) {
>> +                             /* zeroed flags, remove query */
>> +                             if (verbose)
>> +                                     pr_info("delete pending: %s\n",
>> +                                             show_pending_query(pq));
>
> I think these should be pr_debug.
> I know you're only using the current style.
>
> Jason, any reason these can not be converted?
>
>

hi Joe,

one other corner case (in addition to pr_cont, which I probly should
have addressed to you)

+#define pr_fmt(fmt) KBUILD_MODNAME ":%s: " fmt, __func__

makes pr_debug unconditionally print stuff that can be
doubled up if flags are also used.

Ive done s/pr_info/pr_debug/ locally, when combined with:
  ddebug_query="module dynamic_debug +pfmlt "
lines are too long, and are redundant

This is pretty trivial, and can be avoided by
"dont add those flags then", but I could imagine it
being a minor annoyance wherever both pr_debug
and pr_info|warn|err|etc are used together.

Perhaps pr_debug and friends should ignore pr_fmt
under CONFIG_DYNAMIC_DEBUG ?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ