lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 3 May 2012 09:10:07 +0200
From:	Hans Verkuil <hverkuil@...all.nl>
To:	manjunatha_halli@...com
Cc:	linux-media@...r.kernel.org, linux-kernel@...r.kernel.org,
	Manjunatha Halli <x0130808@...com>
Subject: Re: [PATCH V3 2/5] [Media] New control class and features for FM RX

On Thu May 3 2012 09:08:57 Hans Verkuil wrote:
> Just a few more minor notes:
> 
> On Wed May 2 2012 23:42:28 manjunatha_halli@...com wrote:
> > From: Manjunatha Halli <x0130808@...com>
> > 
> > This patch creates new ctrl class for FM RX and adds new CID's for
> > below FM features,
> >         1) De-Emphasis filter mode
> > 	2) RDS AF switch
> > 
> > Also this patch adds a field for band selection in struct v4l2_hw_freq_seek
> > 
> > Signed-off-by: Manjunatha Halli <x0130808@...com>
> > ---
> >  drivers/media/video/v4l2-ctrls.c |   17 +++++++++++++++++
> >  include/linux/videodev2.h        |   11 ++++++++++-
> >  2 files changed, 27 insertions(+), 1 deletions(-)
> > 
> > diff --git a/drivers/media/video/v4l2-ctrls.c b/drivers/media/video/v4l2-ctrls.c
> > index 18015c0..e1bba7d 100644
> > --- a/drivers/media/video/v4l2-ctrls.c
> > +++ b/drivers/media/video/v4l2-ctrls.c
> > @@ -372,6 +372,12 @@ const char * const *v4l2_ctrl_get_menu(u32 id)
> >  		NULL,
> >  	};
> >  
> > +	static const char * const tune_deemphasis[] = {
> > +		"No deemphasis",
> > +		"50 useconds",
> > +		"75 useconds",
> > +		NULL,
> > +	};
> 
> I suggest that we re-use tune_preemphasis[] here. Just replace the first
> entry from "No Preemphasis" to "None" to make it generic.
> 
> Rename tune_preemphasis[] to tune_emphasis[] as well.
> 
> >  	switch (id) {
> >  	case V4L2_CID_MPEG_AUDIO_SAMPLING_FREQ:
> >  		return mpeg_audio_sampling_freq;
> > @@ -414,6 +420,8 @@ const char * const *v4l2_ctrl_get_menu(u32 id)
> >  		return colorfx;
> >  	case V4L2_CID_TUNE_PREEMPHASIS:
> >  		return tune_preemphasis;
> > +	case V4L2_CID_TUNE_DEEMPHASIS:
> > +		return tune_deemphasis;
> >  	case V4L2_CID_FLASH_LED_MODE:
> >  		return flash_led_mode;
> >  	case V4L2_CID_FLASH_STROBE_SOURCE:
> > @@ -644,6 +652,12 @@ const char *v4l2_ctrl_get_name(u32 id)
> >  	case V4L2_CID_JPEG_COMPRESSION_QUALITY:	return "Compression Quality";
> >  	case V4L2_CID_JPEG_ACTIVE_MARKER:	return "Active Markers";
> >  
> > +	/* FM Radio Receiver control */
> > +	/* Keep the order of the 'case's the same as in videodev2.h! */
> > +	case V4L2_CID_FM_RX_CLASS:		return "FM Radio Receiver Controls";
> > +	case V4L2_CID_RDS_AF_SWITCH:		return "FM RX RDS AF switch";
> 
> I would call this "RDS AF Switch" or perhaps even better: "RDS Auto-Frequency Switch"

Sorry, that should have been: "RDS Alternate Frequency Switch".

Regards,

	Hans

> 
> > +	case V4L2_CID_TUNE_DEEMPHASIS:		return "FM RX De-emphasis settings";
> 
> Rename to "De-Emphasis" to be consistent with the existing "Pre-Emphasis" string.
> 
> Regards,
> 
> 	Hans
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ