lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 14 May 2012 18:11:20 -0700
From:	Stephen Boyd <sboyd@...cinc.com>
To:	Tejun Heo <tj@...nel.org>
CC:	Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
	Yinghai Lu <yinghai@...nel.org>,
	Benjamin Herrenschmidt <benh@...nel.crashing.org>
Subject: memblock_is_region_memory() vs. memblock_is_region_reserved()

I was looking at memblock and noticed that memblock_is_region_memory()
is implemented differently than memblock_is_region_reserved().

memblock_is_region_memory() returns true only if the region you are
testing is fully contained within the bounds of a memory block. If the
region is half in and half out of a memory region (i.e. overlaps memory
and a hole) it is not memory and returns false.

memblock_is_region_reserved() is the opposite. If the region are you are
testing is half in and half out of a reserved region (i.e. overlaps
reserved memory) it returns true, otherwise it returns false.

These functions sound like they do the same thing by testing to see if
what you specify is either memory or reserved memory, but the semantics
are a bit different in that the former doesn't allow overlap, and the
latter accepts overlap. Should we rename memblock_is_region_reserved()
to memblock_overlaps_reserved() to make it clearer what the intention
is? Or perhaps rename memblock_is_region_memory() to
memblock_is_region_within_memory()?

If anything, perhaps this patch will help clarify things?

diff --git a/mm/memblock.c b/mm/memblock.c
index a44eab3..f097e79 100644
--- a/mm/memblock.c
+++ b/mm/memblock.c
@@ -855,6 +855,16 @@ int __init_memblock memblock_is_memory(phys_addr_t addr)
 	return memblock_search(&memblock.memory, addr) != -1;
 }
 
+/**
+ * memblock_is_region_memory - check if a region is a subset of memory
+ * @base: base of region to check
+ * @size: size of region to check
+ *
+ * Check if the region [@base, @base+@...e) is a subset of a memory block.
+ *
+ * RETURNS:
+ * 0 if false, non-zero if true
+ */
 int __init_memblock memblock_is_region_memory(phys_addr_t base, phys_addr_t size)
 {
 	int idx = memblock_search(&memblock.memory, base);
@@ -867,6 +877,16 @@ int __init_memblock memblock_is_region_memory(phys_addr_t base, phys_addr_t size
 		 memblock.memory.regions[idx].size) >= end;
 }
 
+/**
+ * memblock_is_region_reserved - check if a region intersects reserved memory
+ * @base: base of region to check
+ * @size: size of region to check
+ *
+ * Check if the region [@base, @base+@...e) intersects a reserved memory block.
+ *
+ * RETURNS:
+ * 0 if false, non-zero if true
+ */
 int __init_memblock memblock_is_region_reserved(phys_addr_t base, phys_addr_t size)
 {
 	memblock_cap_size(base, &size);

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ