lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 24 Jun 2012 11:09:08 +0100
From:	Al Viro <viro@...IV.linux.org.uk>
To:	Oleg Nesterov <oleg@...hat.com>
Cc:	Mimi Zohar <zohar@...ux.vnet.ibm.com>,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	". James Morris" <jmorris@...ei.org>,
	linux-security-module@...r.kernel.org,
	linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: deferring __fput()

On Sun, Jun 24, 2012 at 05:16:52AM +0100, Al Viro wrote:
> We could, in principle, add a "ok_late" argument, allowing to add after
> PF_EXITING has been set only if it's true and run the list twice, but
> that's really more convoluted than I would like...
> 
> Comments?

OK...  What I had in mind is (modulo really dire need of saner commit messages
and probably a different ordering/splitup of the first 3 commits) is
in vfs.git#untested.  WARNING: the branch name is no joke; it builds, but
I hadn't even tried to boot the resulting kernel yet.

Comments would be very welcome.  It should get us the situation when
	* __fput() is always called with no locks held by caller and
can take any locks whatsoever.
	* fput() is legal to call from any contexts
	* fput() done by a syscall will be completed before the process
returns to userland or terminates
	* no extra context switches, unless we have the final fput() done
from interrupt (instant death on the current kernel) or from the
kernel thread.
	* SCM_RIGHTS datagram destruction should be no worse than it is now;
probably a bit kinder on stack, even...  Again, no extra context switches.
	* Neither struct file nor struct task_struct changed size.
	* task_work and rcu_head are identical at that point; I'd appreciate
a better name (I ended up calling that sucker callback_head, defined in
types.h, with #define rcu_head callback_head next to it, to avoid global
rename from hell).  I can live with two identical structs (and a union
of those two in a few places), but I really see no point in going that way.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ