lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 13 Nov 2012 16:48:11 -0800
From:	Greg KH <gregkh@...uxfoundation.org>
To:	Constantine Shulyupin <const@...elinux.com>
Cc:	linux-kernel@...r.kernel.org, celinux-dev@...ts.celinuxforum.org
Subject: Re: [PATCH] LDT - Linux Driver Template

On Wed, Nov 14, 2012 at 02:14:58AM +0200, Constantine Shulyupin wrote:
> On Tue, Nov 13, 2012 at 9:01 PM, Greg KH <gregkh@...uxfoundation.org> wrote:
> >> +#define pr_debug_hex(h)      pr_debug("%s:%d %s %s = 0x%lX\n", \
> >> +     __file__, __LINE__, __func__, #h, (long int)h)
> >
> > This is not needed at all, just use the proper printk() attribute.
> 
> Macro above allows tidy tracing code:
> 
>         pr_debug_hex(ioread8(port_ptr + UART_IER));
>         pr_debug_hex(ioread8(port_ptr + UART_IIR));
>         pr_debug_hex(ioread8(port_ptr + UART_FCR));
>         pr_debug_hex(ioread8(port_ptr + UART_LCR));
>         pr_debug_hex(ioread8(port_ptr + UART_MCR));
>         pr_debug_hex(ioread8(port_ptr + UART_LSR));
>         pr_debug_hex(ioread8(port_ptr + UART_MSR));
> 
> Without that macro, code above should be rewritten with pr_debug (or printk) as:
> 
>         pr_debug("UART_IER=0x%02X\n", ioread8(port_ptr + UART_IER));
>         pr_debug("UART_IIR=0x%02X\n", ioread8(port_ptr + UART_IIR));
>         pr_debug("UART_FCR=0x%02X\n", ioread8(port_ptr + UART_FCR));
>         pr_debug("UART_LCR=0x%02X\n", ioread8(port_ptr + UART_LCR));
>         pr_debug("UART_MCR=0x%02X\n", ioread8(port_ptr + UART_MCR));
>         pr_debug("UART_LSR=0x%02X\n", ioread8(port_ptr + UART_LSR));
>         pr_debug("UART_MSR=0x%02X\n", ioread8(port_ptr + UART_MSR));
> 
> That is less readable and less supportable.

What better is to not do foolish stuff like this at all :)

If you need tracing, use the in-kernel tracing framework, don't roll
your own.

> I prefer the fist case.

I prefer the flower case :)

> Actually I use a lot shorter macro:
> #define traceh(h)   printk("%s = 0x%lX\n", #h, (long int)h)
> 
> What is you opinion? Which method is better?

Again, neither, don't clutter your code up with unneeded things like
this.

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ