lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 15 Mar 2013 00:30:42 +0000 (GMT)
From:	Jingoo Han <jg1.han@...sung.com>
To:	Doug Anderson <dianders@...omium.org>, Felipe Balbi <balbi@...com>
Cc:	Alexander Graf <agraf@...e.de>,
	Vivek Gautam <gautam.vivek@...sung.com>,
	Alan Stern <stern@...land.harvard.edu>,
	Kukjin Kim <kgene.kim@...sung.com>,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	Thomas Abraham <thomas.abraham@...aro.org>,
	"linux-usb@...r.kernel.org" <linux-usb@...r.kernel.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	Jingoo Han <jg1.han@...sung.com>
Subject: Re: [PATCH] usb: ehci-s5p: Use devm for requesting ehci_vbus_gpio

On Wednesday, March 13, 2013 4:03 AM, Doug Anderson wrote:
> 
> The ehci_vbus_gpio is requested but never freed.  This can cause
> problems with deferred probes and would cause problems if
> s5p_ehci_remove was ever called.  Use devm to fix this.
> 
> Signed-off-by: Doug Anderson <dianders@...omium.org>
> ---
>  drivers/usb/host/ehci-s5p.c | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/usb/host/ehci-s5p.c b/drivers/usb/host/ehci-s5p.c
> index 20ebf6a..a464197 100644
> --- a/drivers/usb/host/ehci-s5p.c
> +++ b/drivers/usb/host/ehci-s5p.c
> @@ -92,6 +92,7 @@ static void s5p_ehci_phy_disable(struct s5p_ehci_hcd *s5p_ehci)
> 
>  static void s5p_setup_vbus_gpio(struct platform_device *pdev)
>  {
> +	struct device *dev = &pdev->dev;

Hi Doug Anderson,

Would you replace other '&pdev->dev' with 'dev' in s5p_setup_vbus_gpio()
as below? It seems to be better for readability.

-       gpio = of_get_named_gpio(pdev->dev.of_node,
+       gpio = of_get_named_gpio(dev->of_node,
                        "samsung,vbus-gpio", 0);
        if (!gpio_is_valid(gpio))
                return;

-       err = gpio_request_one(gpio, GPIOF_OUT_INIT_HIGH, "ehci_vbus_gpio");
+       err = devm_gpio_request_one(dev, gpio, GPIOF_OUT_INIT_HIGH,
+                               "ehci_vbus_gpio");
        if (err)
-               dev_err(&pdev->dev, "can't request ehci vbus gpio %d", gpio);
+               dev_err(dev, "can't request ehci vbus gpio %d", gpio);


Best regards,
Jingoo Han

>  	int err;
>  	int gpio;
> 
> @@ -103,7 +104,8 @@ static void s5p_setup_vbus_gpio(struct platform_device *pdev)
>  	if (!gpio_is_valid(gpio))
>  		return;
> 
> -	err = gpio_request_one(gpio, GPIOF_OUT_INIT_HIGH, "ehci_vbus_gpio");
> +	err = devm_gpio_request_one(dev, gpio, GPIOF_OUT_INIT_HIGH,
> +				    "ehci_vbus_gpio");
>  	if (err)
>  		dev_err(&pdev->dev, "can't request ehci vbus gpio %d", gpio);
>  }
> --
> 1.8.1.3

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ