lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 07 May 2013 10:15:05 +0200
From:	Daniel Borkmann <dborkman@...hat.com>
To:	y@...inux1.ap.freescale.net
CC:	linux-kernel@...r.kernel.org, davem@...emloft.net,
	tglx@...utronix.de, john.stultz@...aro.org, liu.y.victor@...il.com,
	Liu Ying <Ying.Liu@...escale.com>
Subject: Re: [PATCH 1/1] ktime: Use macro NSEC_PER_USEC instead of a magic
 number

On 05/06/2013 02:42 PM, y@...inux1.ap.freescale.net wrote:
> From: Liu Ying <Ying.Liu@...escale.com>

Nitpick:

If you only have 1 patch, then you don't need "1/1" in the subject.
The term magic number here might be a little exaggerated, not so
magic actually. :-)

But, in general I agree that we could do that also since it is used
elsewhere in the same header file. Thus, this might be more consistent.

> We've got the macro NSEC_PER_USEC defined in header file
> include/linux/time.h. To make the code decent, this patch
> replaces the magic number 1000 to convert bewteen a time
> value in microseconds and one in nanoseconds with the
> macro NSEC_PER_USEC.
>
> Signed-off-by: Liu Ying <Ying.Liu@...escale.com>
> Cc: David S. Miller <davem@...emloft.net>
> Cc: Daniel Borkmann <dborkman@...hat.com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: John Stultz <john.stultz@...aro.org>
> ---
>   include/linux/ktime.h |    7 ++++---
>   1 files changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/include/linux/ktime.h b/include/linux/ktime.h
> index bbca128..5de963d 100644
> --- a/include/linux/ktime.h
> +++ b/include/linux/ktime.h
> @@ -229,7 +229,8 @@ static inline ktime_t timespec_to_ktime(const struct timespec ts)
>   static inline ktime_t timeval_to_ktime(const struct timeval tv)
>   {
>   	return (ktime_t) { .tv = { .sec = (s32)tv.tv_sec,
> -				   .nsec = (s32)tv.tv_usec * 1000 } };
> +				   .nsec = (s32)tv.tv_usec *
> +					   (s32)NSEC_PER_USEC} };

Nitpick: Likely, this could be reduced to one cast only.

Otherwise looks good.

>   }
>
>   /**
> @@ -320,12 +321,12 @@ static inline s64 ktime_us_delta(const ktime_t later, const ktime_t earlier)
>
>   static inline ktime_t ktime_add_us(const ktime_t kt, const u64 usec)
>   {
> -	return ktime_add_ns(kt, usec * 1000);
> +	return ktime_add_ns(kt, usec * NSEC_PER_USEC);
>   }
>
>   static inline ktime_t ktime_sub_us(const ktime_t kt, const u64 usec)
>   {
> -	return ktime_sub_ns(kt, usec * 1000);
> +	return ktime_sub_ns(kt, usec * NSEC_PER_USEC);
>   }
>
>   extern ktime_t ktime_add_safe(const ktime_t lhs, const ktime_t rhs);
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ