lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 05 May 2014 16:22:48 +0800
From:	Jiang Liu <jiang.liu@...ux.intel.com>
To:	Bjorn Helgaas <bhelgaas@...gle.com>
CC:	Joerg Roedel <joro@...tes.org>,
	David Woodhouse <dwmw2@...radead.org>,
	Yinghai Lu <yinghai@...nel.org>,
	Dan Williams <dan.j.williams@...el.com>,
	Vinod Koul <vinod.koul@...el.com>,
	"Rafael J . Wysocki" <rafael.j.wysocki@...el.com>,
	"Rafael J. Wysocki" <rjw@...ysocki.net>,
	Len Brown <lenb@...nel.org>, Ashok Raj <ashok.raj@...el.com>,
	Yijing Wang <wangyijing@...wei.com>,
	Tony Luck <tony.luck@...el.com>,
	iommu@...ts.linux-foundation.org, linux-pci@...r.kernel.org,
	linux-kernel@...r.kernel.org, dmaengine@...r.kernel.org,
	linux-acpi@...r.kernel.org
Subject: Re: [Patch Part3 V1 17/22] pci, ACPI, iommu: enhance pci_root to
 support DMAR device hotplug



On 2014/4/25 1:33, Bjorn Helgaas wrote:
> On Tue, Apr 22, 2014 at 03:07:28PM +0800, Jiang Liu wrote:
>> Finally enhance pci_root driver to support DMAR device hotplug when
>> hot-plugging PCI host bridges.
>>
>> Signed-off-by: Jiang Liu <jiang.liu@...ux.intel.com>
>> ---
>>  drivers/acpi/pci_root.c |   16 ++++++++++++++--
>>  1 file changed, 14 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/acpi/pci_root.c b/drivers/acpi/pci_root.c
>> index d388f13d48b4..aa8f549869f3 100644
>> --- a/drivers/acpi/pci_root.c
>> +++ b/drivers/acpi/pci_root.c
>> @@ -33,6 +33,7 @@
>>  #include <linux/pci.h>
>>  #include <linux/pci-acpi.h>
>>  #include <linux/pci-aspm.h>
>> +#include <linux/dmar.h>
>>  #include <linux/acpi.h>
>>  #include <linux/slab.h>
>>  #include <acpi/apei.h>	/* for acpi_hest_init() */
>> @@ -511,6 +512,7 @@ static int acpi_pci_root_add(struct acpi_device *device,
>>  	struct acpi_pci_root *root;
>>  	acpi_handle handle = device->handle;
>>  	int no_aspm = 0, clear_aspm = 0;
>> +	bool hotadd = (system_state != SYSTEM_BOOTING);
>>  
>>  	root = kzalloc(sizeof(struct acpi_pci_root), GFP_KERNEL);
>>  	if (!root)
>> @@ -557,6 +559,11 @@ static int acpi_pci_root_add(struct acpi_device *device,
>>  	strcpy(acpi_device_class(device), ACPI_PCI_ROOT_CLASS);
>>  	device->driver_data = root;
>>  
>> +	if (hotadd && dmar_device_hotplug(handle, true)) {
> 
> Apparently "dmar_device_hotplug(handle, true)" means "add a DMAR device,"
> and "dmar_device_hotplug(device->handle, false)" means "remove a DMAR
> device."  I'm not really a fan of interfaces where one of the arguments
> selects between two completely different actions, because it's harder for a
> casual reader to see what's going on.
> 
> I see how it simplifies your implementation a little bit, but I think it's
> more important to simplify for the reader.
Thanks Bjorn, I will rename it to dmar_device_add/remove() instead.

> 
> Bjorn
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ