lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Wed, 27 Aug 2014 13:13:53 +0300
From:	Dan Carpenter <dan.carpenter@...cle.com>
To:	Brian Norris <computersforpeace@...il.com>
Cc:	Julia Lawall <julia.lawall@...6.fr>,
	Marc Carino <marc.ceeeee@...il.com>,
	kernel-janitors@...r.kernel.org,
	Christian Daudt <bcm@...thebug.org>,
	Matt Porter <mporter@...aro.org>,
	Russell King <linux@....linux.org.uk>,
	linux-arm-kernel@...ts.infradead.org,
	bcm-kernel-feedback-list@...adcom.com,
	linux-kernel@...r.kernel.org,
	Uwe Kleine-König 
	<u.kleine-koenig@...gutronix.de>
Subject: Re: [PATCH 11/14] ARM: brcmstb: delete unneeded test before
 of_node_put

On Wed, Aug 13, 2014 at 11:53:10PM -0700, Brian Norris wrote:
> > > >  cleanup:
> > > > -	if (syscon_np)
> > > > -		of_node_put(syscon_np);
> > > > -
> > > > +	of_node_put(syscon_np);
> > > > +out:
> > > 
> > > Is there a good reason for this new label? I thought part of the point
> > > of this semantic patch is that the previous line (of_node_put()) is a
> > > no-op for NULL arguments.
> > 
> > Personally, I prefer code to only be executed if it needs to be.  It is 
> > helpful from a program analysis point of view, and I think it helps 
> > someone trying to understand the code.
> > 
> > That is, when I am trying to understand some unknown code, I may look at 
> > the cleanup code and try to figure out why each piece of it is executed.  
> > If some of it is statically known to be irrelevant, it is confusing.
> > 
> > But I you think the other way around, and would rather have just one label 
> > that contains anything that might ever be useful, then I guess that is a 
> > reasonable point of view as well.
> 
> Yeah, I personally just look to avoid unnecessary labels.
> 

Having more than one label is better because it helps you avoid "One Err
Bugs".  This is a common kind of bug which is cause when functions have
only one "err:" label which does all the error handling.

Some examples of this type of bug are:
234ad18249a4 ('staging: gdm7240: fix error handling of probe()')
85a258b70d48 ('ocfs2: fix error handling in ocfs2_ioctl_move_extents()')
920c4f4c3651 ('drivers/leds/leds-tca6507.c: cleanup error handling in tca6507_probe()')

If you unwind in the exact reversed order of how things were allocated
then it makes the code a lot easier to understand so it avoids bugs.

regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ