lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 5 Nov 2014 16:57:11 +0100
From:	Petr Mladek <pmladek@...e.cz>
To:	Steven Rostedt <rostedt@...dmis.org>
Cc:	linux-kernel@...r.kernel.org, Ingo Molnar <mingo@...nel.org>,
	Andrew Morton <akpm@...ux-foundation.org>,
	Jiri Kosina <jkosina@...e.cz>,
	"H. Peter Anvin" <hpa@...or.com>,
	Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [RFC][PATCH 05/12 v3] tracing: Convert seq_buf fields to be like
 seq_file fields

On Tue 2014-11-04 10:52:42, Steven Rostedt wrote:
> From: "Steven Rostedt (Red Hat)" <rostedt@...dmis.org>
> 
> In facilitating the conversion of seq_file to use seq_buf,
> have the seq_buf fields match the types used by seq_file.
> 
> Signed-off-by: Steven Rostedt <rostedt@...dmis.org>
> ---
>  include/linux/seq_buf.h | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/include/linux/seq_buf.h b/include/linux/seq_buf.h
> index 6d1c57d6073f..a4d114e6f740 100644
> --- a/include/linux/seq_buf.h
> +++ b/include/linux/seq_buf.h
> @@ -19,10 +19,10 @@
>   * @overflow:	Set if more bytes should have been written to buffer
>   */
>  struct seq_buf {
> -	unsigned char		*buffer;
> -	unsigned int		size;
> -	unsigned int		len;
> -	unsigned int		readpos;
> +	char			*buffer;

It would make sense to use "char" from the beginning. In fact, it is
already used on many locations in seq_buf.c. Or we might want to get
rid of "unsigned char" in seq_buf.c here as well.

> +	size_t			size;
> +	size_t			len;
> +	loff_t			readpos;

I have just noticed that the variable is called "read_pos" in
seq_file. Are you going to sync the name later?

Also I am a bit curious that "readpos" use another type than "len"
and "size". Well, this is not in the scope of this patchset. I am fine
with keeping "loff_t" at this point.

Best Regards,
Petr
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ