lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 17 Nov 2014 12:06:31 +0530
From:	Vivek Gautam <gautamvivek1987@...il.com>
To:	Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
Cc:	Vivek Gautam <gautam.vivek@...sung.com>,
	Linux USB Mailing List <linux-usb@...r.kernel.org>,
	"linux-samsung-soc@...r.kernel.org" 
	<linux-samsung-soc@...r.kernel.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"linux-arm-kernel@...ts.infradead.org" 
	<linux-arm-kernel@...ts.infradead.org>,
	Greg KH <gregkh@...uxfoundation.org>, kishon <kishon@...com>,
	Felipe Balbi <balbi@...com>,
	Alan Stern <stern@...land.harvard.edu>,
	Kukjin Kim <kgene.kim@...sung.com>,
	Heikki Krogerus <heikki.krogerus@...ux.intel.com>,
	Mathias Nyman <mathias.nyman@...el.com>,
	Julius Werner <jwerner@...gle.com>,
	Jingoo Han <jg1.han@...sung.com>
Subject: Re: [PATCH v7 1/2] usb: host: xhci-plat: Get PHYs for xhci's hcds

Hi,


On Fri, Oct 31, 2014 at 7:21 PM, Sergei Shtylyov
<sergei.shtylyov@...entembedded.com> wrote:
> Hello.
>
> On 10/31/2014 4:26 PM, Vivek Gautam wrote:
>
>> The host controller by itself may sometimes need to handle PHY
>> and re-initialize it to re-configure some of the PHY parameters
>> to get full support out of the PHY controller.
>> Therefore, facilitate getting the two possible PHYs, viz.
>> USB 2.0 type (UTMI+) and USB 3.0 type (PIPE3), and initialize them.
>
>
>> Signed-off-by: Vivek Gautam <gautam.vivek@...sung.com>
>> ---
>>   drivers/usb/host/xhci-plat.c |   74
>> ++++++++++++++++++++++++++++++++++++++++++
>>   1 file changed, 74 insertions(+)
>
>
>> diff --git a/drivers/usb/host/xhci-plat.c b/drivers/usb/host/xhci-plat.c
>> index 3d78b0c..5207d5b 100644
>> --- a/drivers/usb/host/xhci-plat.c
>> +++ b/drivers/usb/host/xhci-plat.c
>
> [...]
>>
>> @@ -129,10 +130,41 @@ static int xhci_plat_probe(struct platform_device
>> *pdev)
>>                         goto put_hcd;
>>         }
>>
>> +       /* Get possile USB 2.0 type PHY (UTMI+) available with xhci */
>> +       hcd->phy = devm_phy_get(&pdev->dev, "usb2-phy");
>> +       if (IS_ERR(hcd->phy)) {
>> +               ret = PTR_ERR(hcd->phy);
>> +               if (ret == -EPROBE_DEFER) {
>> +                       goto disable_clk;
>> +               } else if (ret != -ENOSYS && ret != -ENODEV) {
>
>
>    Asking to be a *switch* statement instead...

Sure, will change this to *switch* statement. That will improve the
readability.

>
>> +                       hcd->phy = NULL;
>> +                       dev_warn(&pdev->dev,
>> +                                "Error retrieving usb2 phy: %d\n", ret);
>> +               }
>> +       }
>> +
>
> [...]
>>
>> @@ -158,12 +190,41 @@ static int xhci_plat_probe(struct platform_device
>> *pdev)
>>         if (HCC_MAX_PSA(xhci->hcc_params) >= 4)
>>                 xhci->shared_hcd->can_do_streams = 1;
>>
>> +       /* Get possile USB 3.0 type PHY (PIPE3) available with xhci */
>> +       xhci->shared_hcd->phy = devm_phy_get(&pdev->dev, "usb3-phy");
>> +       if (IS_ERR(xhci->shared_hcd->phy)) {
>> +               ret = PTR_ERR(xhci->shared_hcd->phy);
>> +               if (ret == -EPROBE_DEFER) {
>> +                       goto put_usb3_hcd;
>> +               } else if (ret != -ENOSYS && ret != -ENODEV) {
>
>
>    Likewise...

ok

>
>> +                       xhci->shared_hcd->phy = NULL;
>> +                       dev_warn(&pdev->dev,
>> +                                "Error retrieving usb3 phy: %d\n", ret);
>> +               }
>> +       }
>> +
>
> [...]
>>
>> @@ -204,6 +271,8 @@ static int xhci_plat_suspend(struct device *dev)
>>         struct usb_hcd  *hcd = dev_get_drvdata(dev);
>>         struct xhci_hcd *xhci = hcd_to_xhci(hcd);
>>
>> +       phy_exit(hcd->phy);
>
>
>    Hm, in the suspend() method?

phy_exit() should eventually be suspending the PHY and put it to
low power state.
phy_init() in resume() will then take up the task of activating the
PHY again.

phy_power_on() and phy_power_off() are called at xhci_probe() and remove() time.

Does this makes sense ?



-- 
Best Regards
Vivek Gautam
Samsung R&D Institute, Bangalore
India
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ