lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 29 Dec 2014 10:56:02 +0100
From:	Martin Schwidefsky <schwidefsky@...ibm.com>
To:	Aniroop Mathur <aniroop.mathur@...il.com>
Cc:	<heiko.carstens@...ibm.com>, <linux390@...ibm.com>,
	<linux-s390@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
	<a.mathur@...sung.com>
Subject: Re: [PATCH] s390: Initialize nr_devices count variable to -1

On Sun, 28 Dec 2014 21:42:53 +0530
Aniroop Mathur <aniroop.mathur@...il.com> wrote:

> From: Aniroop Mathur <a.mathur@...sung.com>
> 
> This patch initializes nr_device count variable to -1 to avoid extra
> subtraction operation performed everytime scm block device is set up.
> 
> Signed-off-by: Aniroop Mathur <a.mathur@...sung.com>
> ---
>  drivers/s390/block/scm_blk.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/s390/block/scm_blk.c b/drivers/s390/block/scm_blk.c
> index 76bed17..ee2bd6f 100644
> --- a/drivers/s390/block/scm_blk.c
> +++ b/drivers/s390/block/scm_blk.c
> @@ -23,7 +23,7 @@ static int scm_major;
>  static DEFINE_SPINLOCK(list_lock);
>  static LIST_HEAD(inactive_requests);
>  static unsigned int nr_requests = 64;
> -static atomic_t nr_devices = ATOMIC_INIT(0);
> +static atomic_t nr_devices = ATOMIC_INIT(-1);
>  module_param(nr_requests, uint, S_IRUGO);
>  MODULE_PARM_DESC(nr_requests, "Number of parallel requests.");
> 
> @@ -357,7 +357,7 @@ int scm_blk_dev_setup(struct scm_blk_dev *bdev, struct scm_device *scmdev)
>  	int len, ret = -ENOMEM;
>  	unsigned int devindex, nr_max_blk;
> 
> -	devindex = atomic_inc_return(&nr_devices) - 1;
> +	devindex = atomic_inc_return(&nr_devices);
>  	/* scma..scmz + scmaa..scmzz */
>  	if (devindex > 701) {
>  		ret = -ENODEV;

This patch makes the code harder to read to avoid a single subtraction at
device setup time. I prefer readability.

-- 
blue skies,
   Martin.

"Reality continues to ruin my life." - Calvin.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ