lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 06 Feb 2015 15:02:05 +0100
From:	Tomeu Vizoso <tomeu.vizoso@...labora.com>
To:	Stephen Boyd <sboyd@...eaurora.org>,
	Mike Turquette <mturquette@...aro.org>
CC:	linux-kernel@...r.kernel.org,
	Alban Browaeys <alban.browaeys@...il.com>
Subject: Re: [PATCH 2/3] clk: Rename child_node to clks_node to avoid confusion

On 02/06/2015 01:19 AM, Stephen Boyd wrote:
> The child_node member of struct clk is named the same as the
> child_node member of struct clk_core. Let's rename the struct
> clk's member to clks_node to avoid getting confused with the
> child_node member of struct clk_core and to match the name of the
> list head, clks.
> 
> Cc: Tomeu Vizoso <tomeu.vizoso@...labora.com>
> Cc: Alban Browaeys <alban.browaeys@...il.com>
> Signed-off-by: Stephen Boyd <sboyd@...eaurora.org>
> ---
>  drivers/clk/clk.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)

Yeah, I like this better.

Reviewed-by: Tomeu Vizoso <tomeu.vizoso@...labora.com>

Thanks,

Tomeu

> diff --git a/drivers/clk/clk.c b/drivers/clk/clk.c
> index 5469d7714f5d..315dc22b7356 100644
> --- a/drivers/clk/clk.c
> +++ b/drivers/clk/clk.c
> @@ -83,7 +83,7 @@ struct clk {
>  	const char *con_id;
>  	unsigned long min_rate;
>  	unsigned long max_rate;
> -	struct hlist_node child_node;
> +	struct hlist_node clks_node;
>  };
>  
>  /***           locking             ***/
> @@ -851,10 +851,10 @@ static void clk_core_get_boundaries(struct clk_core *clk,
>  	*min_rate = 0;
>  	*max_rate = ULONG_MAX;
>  
> -	hlist_for_each_entry(clk_user, &clk->clks, child_node)
> +	hlist_for_each_entry(clk_user, &clk->clks, clks_node)
>  		*min_rate = max(*min_rate, clk_user->min_rate);
>  
> -	hlist_for_each_entry(clk_user, &clk->clks, child_node)
> +	hlist_for_each_entry(clk_user, &clk->clks, clks_node)
>  		*max_rate = min(*max_rate, clk_user->max_rate);
>  }
>  
> @@ -2376,7 +2376,7 @@ struct clk *__clk_create_clk(struct clk_hw *hw, const char *dev_id,
>  	clk->max_rate = ULONG_MAX;
>  
>  	clk_prepare_lock();
> -	hlist_add_head(&clk->child_node, &hw->core->clks);
> +	hlist_add_head(&clk->clks_node, &hw->core->clks);
>  	clk_prepare_unlock();
>  
>  	return clk;
> @@ -2385,7 +2385,7 @@ struct clk *__clk_create_clk(struct clk_hw *hw, const char *dev_id,
>  void __clk_free_clk(struct clk *clk)
>  {
>  	clk_prepare_lock();
> -	hlist_del(&clk->child_node);
> +	hlist_del(&clk->clks_node);
>  	clk_prepare_unlock();
>  
>  	kfree(clk);
> @@ -2663,7 +2663,7 @@ void __clk_put(struct clk *clk)
>  
>  	clk_prepare_lock();
>  
> -	hlist_del(&clk->child_node);
> +	hlist_del(&clk->clks_node);
>  	clk_core_set_rate_nolock(clk->core, clk->core->req_rate);
>  	owner = clk->core->owner;
>  	kref_put(&clk->core->ref, __clk_release);
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ