lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 6 Mar 2015 08:30:45 +0100
From:	Ingo Molnar <mingo@...nel.org>
To:	Andy Lutomirski <luto@...capital.net>
Cc:	x86@...nel.org, linux-kernel@...r.kernel.org,
	Borislav Petkov <bp@...en8.de>,
	Oleg Nesterov <oleg@...hat.com>,
	Denys Vlasenko <dvlasenk@...hat.com>,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	Thomas Gleixner <tglx@...utronix.de>,
	"H. Peter Anvin" <hpa@...or.com>
Subject: Re: [PATCH v2 6/6] x86, asm: Rename INIT_TSS_IST to TSS_IST


* Andy Lutomirski <luto@...capital.net> wrote:

> This has nothing to do with the init thread or the initial anything.
> It's just the TSS.
> 
> Signed-off-by: Andy Lutomirski <luto@...capital.net>
> ---
>  arch/x86/kernel/entry_64.S | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/x86/kernel/entry_64.S b/arch/x86/kernel/entry_64.S
> index 0c00fd80249a..c86f83e95f15 100644
> --- a/arch/x86/kernel/entry_64.S
> +++ b/arch/x86/kernel/entry_64.S
> @@ -959,7 +959,7 @@ apicinterrupt IRQ_WORK_VECTOR \
>  /*
>   * Exception entry points.
>   */
> -#define INIT_TSS_IST(x) PER_CPU_VAR(cpu_tss) + (TSS_ist + ((x) - 1) * 8)
> +#define TSS_IST(x) PER_CPU_VAR(cpu_tss) + (TSS_ist + ((x) - 1) * 8)
>  
>  .macro idtentry sym do_sym has_error_code:req paranoid=0 shift_ist=-1
>  ENTRY(\sym)
> @@ -1015,13 +1015,13 @@ ENTRY(\sym)
>  	.endif
>  
>  	.if \shift_ist != -1
> -	subq $EXCEPTION_STKSZ, INIT_TSS_IST(\shift_ist)
> +	subq $EXCEPTION_STKSZ, TSS_IST(\shift_ist)
>  	.endif
>  
>  	call \do_sym
>  
>  	.if \shift_ist != -1
> -	addq $EXCEPTION_STKSZ, INIT_TSS_IST(\shift_ist)
> +	addq $EXCEPTION_STKSZ, TSS_IST(\shift_ist)
>  	.endif
>  
>  	/* these procedures expect "no swapgs" flag in ebx */

If you don't mind I've renamed this to 'CPU_TSS_IST', to be in line 
with cpu_tss.

The per-cpuness of this symbol gets lost at the usage sites, because 
the PER_CPU_VAR() reference is hidden in a macro.

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ