lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 08 May 2015 17:02:25 +0900
From:	Masami Hiramatsu <masami.hiramatsu.pt@...achi.com>
To:	He Kuang <hekuang@...wei.com>, ast@...mgrid.com,
	davem@...emloft.net, acme@...nel.org, mingo@...hat.com,
	a.p.zijlstra@...llo.nl, jolsa@...nel.org
CC:	wangnan0@...wei.com, lizefan@...nel.org,
	linux-kernel@...r.kernel.org, pi3orama@....com
Subject: Re: [RFC PATCH 2/6] perf bpf: Add pt_regs convert table for x86

On 2015/05/05 19:10, He Kuang wrote:
> Convert register number in debuginfo to its index in pt_regs.
> 

This seems better introduced after 3/6, since 3/6 is generic
framework. Without 3/6, this can't do anything.

> Signed-off-by: He Kuang <hekuang@...wei.com>
> ---
>  tools/perf/arch/x86/util/dwarf-regs.c | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
> 
> diff --git a/tools/perf/arch/x86/util/dwarf-regs.c b/tools/perf/arch/x86/util/dwarf-regs.c
> index be22dd4..e586a47 100644
> --- a/tools/perf/arch/x86/util/dwarf-regs.c
> +++ b/tools/perf/arch/x86/util/dwarf-regs.c
> @@ -59,10 +59,31 @@ const char *x86_64_regs_table[X86_64_MAX_REGS] = {
>  	"%r15",
>  };
>  
> +const char x86_64_pt_regs_table[X86_64_MAX_REGS] = {
> +	10,
> +	12,
> +	11,
> +	5,
> +	13,
> +	14,
> +	4,
> +	19,
> +	9,
> +	8,
> +	7,
> +	6,
> +	3,
> +	2,
> +	1,
> +	0,
> +};
> +
>  /* TODO: switching by dwarf address size */
>  #ifdef __x86_64__
>  #define ARCH_MAX_REGS X86_64_MAX_REGS
>  #define arch_regs_table x86_64_regs_table
> +#define arch_pt_regs_table x86_64_pt_regs_table
> +#define arch_pt_regs_type unsigned long

If you need to use this as a type, please use typedef in arch header.

>  #else
>  #define ARCH_MAX_REGS X86_32_MAX_REGS
>  #define arch_regs_table x86_32_regs_table
> @@ -73,3 +94,13 @@ const char *get_arch_regstr(unsigned int n)
>  {
>  	return (n <= ARCH_MAX_REGS) ? arch_regs_table[n] : NULL;
>  }
> +
> +char get_arch_pt_regs(unsigned int n)

Returning char is meaningless. Also this seems returning an index or
offset of pt_regs. If so, get_arch_regoffs() will be better name.

> +{
> +	return (n <= ARCH_MAX_REGS) ? arch_pt_regs_table[n] : -1;
> +}
> +
> +int get_arch_pt_regs_size(void)
> +{
> +	return sizeof(arch_pt_regs_type);
> +}

No, don't do that, since this always returns same value.

Thank you,

-- 
Masami HIRAMATSU
Linux Technology Research Center, System Productivity Research Dept.
Center for Technology Innovation - Systems Engineering
Hitachi, Ltd., Research & Development Group
E-mail: masami.hiramatsu.pt@...achi.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ