lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 24 Jun 2015 23:38:24 +0200
From:	Borislav Petkov <bp@...e.de>
To:	Andy Lutomirski <luto@...nel.org>
Cc:	x86@...nel.org, Peter Zijlstra <peterz@...radead.org>,
	John Stultz <john.stultz@...aro.org>,
	linux-kernel@...r.kernel.org, Len Brown <lenb@...nel.org>,
	Huang Rui <ray.huang@....com>,
	Denys Vlasenko <dvlasenk@...hat.com>, kvm@...r.kernel.org,
	Ralf Baechle <ralf@...ux-mips.org>
Subject: Re: [PATCH v3 13/18] x86/tsc: Rename native_read_tsc() to rdtsc()

On Tue, Jun 16, 2015 at 05:36:01PM -0700, Andy Lutomirski wrote:
> Now that there is no paravirt TSC, the "native" is inappropriate.
> The function does RDTSC, so give it the obvious name: rdtsc()
> 
> Suggested-by: Borislav Petkov <bp@...e.de>
> Signed-off-by: Andy Lutomirski <luto@...nel.org>
> ---
>  arch/x86/boot/compressed/aslr.c                      |  2 +-
>  arch/x86/entry/vdso/vclock_gettime.c                 |  2 +-
>  arch/x86/include/asm/msr.h                           | 11 ++++++++++-
>  arch/x86/include/asm/pvclock.h                       |  2 +-
>  arch/x86/include/asm/stackprotector.h                |  2 +-
>  arch/x86/include/asm/tsc.h                           |  2 +-
>  arch/x86/kernel/apb_timer.c                          |  8 ++++----
>  arch/x86/kernel/apic/apic.c                          |  8 ++++----
>  arch/x86/kernel/cpu/amd.c                            |  4 ++--
>  arch/x86/kernel/cpu/mcheck/mce.c                     |  4 ++--
>  arch/x86/kernel/espfix_64.c                          |  2 +-
>  arch/x86/kernel/hpet.c                               |  4 ++--
>  arch/x86/kernel/trace_clock.c                        |  2 +-
>  arch/x86/kernel/tsc.c                                |  4 ++--
>  arch/x86/kvm/lapic.c                                 |  4 ++--
>  arch/x86/kvm/svm.c                                   |  4 ++--
>  arch/x86/kvm/vmx.c                                   |  4 ++--
>  arch/x86/kvm/x86.c                                   | 12 ++++++------
>  arch/x86/lib/delay.c                                 |  8 ++++----
>  drivers/input/gameport/gameport.c                    |  4 ++--
>  drivers/input/joystick/analog.c                      |  4 ++--
>  drivers/net/hamradio/baycom_epp.c                    |  2 +-
>  drivers/thermal/intel_powerclamp.c                   |  4 ++--
>  tools/power/cpupower/debug/kernel/cpufreq-test_tsc.c |  4 ++--
>  24 files changed, 58 insertions(+), 49 deletions(-)

Btw, just added the hunk below to that one because

4055fad34086 ("intel_pstate: Add tsc collection and keep previous target pstate")

which came in through the pm+acpi pull request added another
native_read_tsc() call:

---
diff --git a/drivers/cpufreq/intel_pstate.c b/drivers/cpufreq/intel_pstate.c
index 15ada47bb720..7c56d7eaa671 100644
--- a/drivers/cpufreq/intel_pstate.c
+++ b/drivers/cpufreq/intel_pstate.c
@@ -765,7 +765,7 @@ static inline void intel_pstate_sample(struct cpudata *cpu)
 	local_irq_save(flags);
 	rdmsrl(MSR_IA32_APERF, aperf);
 	rdmsrl(MSR_IA32_MPERF, mperf);
-	tsc = native_read_tsc();
+	tsc = rdtsc();
 	local_irq_restore(flags);
 
 	cpu->last_sample_time = cpu->sample.time;
---

-- 
Regards/Gruss,
    Boris.

ECO tip #101: Trim your mails when you reply.
--
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ