lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 1 Jul 2015 14:45:27 -0700 (PDT)
From:	David Rientjes <rientjes@...gle.com>
To:	Oleg Nesterov <oleg@...hat.com>
cc:	Andrew Morton <akpm@...ux-foundation.org>,
	Al Viro <viro@...iv.linux.org.uk>,
	Benjamin LaHaise <bcrl@...ck.org>,
	Hugh Dickins <hughd@...gle.com>,
	Jeff Moyer <jmoyer@...hat.com>,
	Kirill Shutemov <kirill.shutemov@...ux.intel.com>,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure

On Sat, 20 Jun 2015, Oleg Nesterov wrote:

> move_vma() sets *locked even if move_page_tables() or ->mremap()
> fails, change sys_mremap() to check "ret & ~PAGE_MASK".
> 
> I think we should simply remove the VM_LOCKED code in move_vma(),
> that is why this patch doesn't change move_vma(). But this needs
> more cleanups.
> 
> Signed-off-by: Oleg Nesterov <oleg@...hat.com>
> ---
>  mm/mremap.c |    4 +++-
>  1 files changed, 3 insertions(+), 1 deletions(-)
> 
> diff --git a/mm/mremap.c b/mm/mremap.c
> index a6306bc..492721c 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -574,8 +574,10 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
>  		ret = move_vma(vma, addr, old_len, new_len, new_addr, &locked);
>  	}
>  out:
> -	if (ret & ~PAGE_MASK)
> +	if (ret & ~PAGE_MASK) {
>  		vm_unacct_memory(charged);
> +		locked = 0;
> +	}
>  	up_write(&current->mm->mmap_sem);
>  	if (locked && new_len > old_len)
>  		mm_populate(new_addr + old_len, new_len - old_len);

Acked-by: David Rientjes <rientjes@...gle.com>

Might be cleaner to rename this to "populate" in sys_mremap() and set it 
to false in the previous old_len >= new_len conditional and remove the 
check here for new_len > old_len.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ