lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 11 Sep 2015 03:29:08 -0400
From:	Raphaël Beamonte <raphael.beamonte@...il.com>
To:	Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc:	Dan Carpenter <dan.carpenter@...cle.com>,
	Raphaël Beamonte <raphael.beamonte@...il.com>,
	Paul Gortmaker <paul.gortmaker@...driver.com>,
	Cristina Opriceana <cristina.opriceana@...il.com>,
	Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
	"Ragnar B. Johannsson" <ragnar@....is>,
	Joe Perches <joe@...ches.com>,
	Marti Bolivar <mbolivarmullen@...il.com>,
	Greg Donald <gdonald@...il.com>,
	Ksenija Stanojevic <ksenija.stanojevic@...il.com>,
	Arnd Bergmann <arnd@...db.de>,
	Luis de Bethencourt <luis@...ethencourt.com>,
	Aya Mahfouz <mahfouz.saif.elyazal@...il.com>,
	Haneen Mohammed <hamohammed.sa@...il.com>,
	Somya Anand <somyaanand214@...il.com>,
	Rene Kolarik <rene.kolarik@...il.com>,
	Vaishali Thakkar <vthakkar1994@...il.com>,
	Melike Yurtoglu <aysemelikeyurtoglu@...il.com>,
	Hatice ERTÜRK <haticeerturk27@...il.com>,
	devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: [PATCHv2 00/16] staging: rtl8192u: code clean up

Hi,

Following comments from Dan Carpenter on my previous patch to
limit the lines lengths for rtl8192u/r8192U_core.c [1], please
find attached a set of patches splitting those operations.

I also took care of keeping the code the more readable possible,
some of those patchs even aim to clean the original content.

The last patch gets rid of the last WARNING of checkpatch about
the 80 lines, as well as the TO_DO_LIST macro that was used in
that module to comment out unused or unusable code.

Thanks,
- R.

[1]: https://lkml.org/lkml/2015/8/19/173


Raphaël Beamonte (16):
  staging: rtl8192u: r8192U_core: fix comments lines over 80 characters
  staging: rtl8192u: r8192U_core: add line breaks to keep lines under 80
    characters
  staging: rtl8192u: r8192U_core: add temporary variables to keep lines
    under 80 characters
  staging: rtl8192u: r8192U_core: reverse conditions to get lines under
    80 characters
  staging: rtl8192u: r8192U_core: rtl8192_adapter_start: reorganize
    function
  staging: rtl8192u: r8192U_core: rtl8192_read_eeprom_info: reorganize
    function
  staging: rtl8192u: r8192U_core: rtl8192_process_phyinfo: rename
    variable pprevious_stats to prev_stats
  staging: rtl8192u: r8192U_core: rtl8192_process_phyinfo: rename
    variable slide_beacon_adc_pwdb_index to sb_index
  staging: rtl8192u: r8192U_core: rtl8192_process_phyinfo: rename
    variable slide_beacon_adc_pwdb_statistics to sb_stats
  staging: rtl8192u: r8192U_core: rtl8192_process_phyinfo: remove
    unneeded variable
  staging: rtl8192u: r8192U_core: rtl8192_process_phyinfo: rename
    variable rfpath to rfp
  staging: rtl8192u: r8192U_core: rtl8192_process_phyinfo: reorganize
    function
  staging: rtl8192u: r8192U_core: rtl8192_tx: replace some inline
    conditions
  staging: rtl8192u: r8192U_core: rtl8192_ioctl: reorganize function
  staging: rtl8192u: r8192U_core: replace else { if() {} } by else if ()
    {}
  staging: rtl8192u: remove all code framed by symbol TO_DO_LIST

 drivers/staging/rtl8192u/ieee80211/ieee80211.h     |    4 +-
 drivers/staging/rtl8192u/ieee80211/ieee80211_tx.c  |   23 -
 .../staging/rtl8192u/ieee80211/rtl819x_HTProc.c    |    4 -
 .../staging/rtl8192u/ieee80211/rtl819x_TSProc.c    |    5 +-
 drivers/staging/rtl8192u/r8192U_core.c             | 1548 ++++++++++++--------
 drivers/staging/rtl8192u/r819xU_phy.c              |   57 -
 6 files changed, 940 insertions(+), 701 deletions(-)

-- 
2.5.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ