lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 1 Oct 2015 11:43:13 +0200
From:	Peter Zijlstra <peterz@...radead.org>
To:	"Meyer, Mike" <Mike.Meyer@...adata.com>
Cc:	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"mingo@...hat.com" <mingo@...hat.com>
Subject: Re: [PATCH] sched: fix task and run queue run_delay inconsistencies

On Thu, Oct 01, 2015 at 08:37:32AM +0200, Peter Zijlstra wrote:
> On Wed, Sep 30, 2015 at 08:28:41PM +0000, Meyer, Mike wrote:

> > Yes that will also address the issue.
> > 
> > The reason I approached the way I did was to avoid adding code path to
> > the far more common uses of {en,de}queue_task() but I doubt anyone is
> > going to notice a difference with the addition of some register
> > save/restores and a compare in that path.  Overall the code does
> > shrink with the alternative which is good.
> 
> In most cases the flags should be compile time constants, and with the
> inline we can determine the branch at compile time, avoiding emitting
> that branch instruction entirely.
> 
> But let me double check the asm for a few important sites.

It looks like the sites in the wakeup path do indeed not get any
additional conditionals.

> > My only comment is I am not sure about the naming of the flag
> > ENQUEUE_TEMP which implies (to me) the enqueue is temporary which
> > clearly it isn't.    Maybe something like DEQUEUE_MOVE/ENQUEUE_MOVE
> > would be a bit more descriptive of the use case.
> 
> Yes, I ran out of creative juices, let me attempt a better name once
> I've woken up a bit.

How about DEQUEUE_SAVE, ENQUEUE_RESTORE ? Ideally I'd wrap the whole
pattern into a helper but C isn't really supportive of pre+post patterns
like this.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ