lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 3 Oct 2015 17:07:02 +0200
From:	Richard Weinberger <richard.weinberger@...il.com>
To:	Alexander Kapshuk <alexander.kapshuk@...il.com>
Cc:	linux-kernel <linux-kernel@...r.kernel.org>,
	Greg KH <gregkh@...uxfoundation.org>
Subject: Re: [PATCH 3/24] ver_linux: gcc.patch

On Sat, Oct 3, 2015 at 3:07 PM, Alexander Kapshuk
<alexander.kapshuk@...il.com> wrote:
> Using 'awk' here is a bit of an overkill. Should the output of 'gcc
> -dumpversion' vary on another disto, or change overtime, it may no longer
> be available at field 1, as relied on by the current implementation.
> I believe 'sed' offers greater flexibility here in terms of processing
> varying output as well as being more light-weight.
>
> Tested on:
> Gentoo Linux
> Debian 6.0.10
> Oracle Linux Server release 7.1
> Arch Linux
> openSuSE 13.2
>
> Signed-off-by: Alexander Kapshuk <alexander.kapshuk@...il.com>
> ---
> --- linux/scripts/ver_linux.orig    2015-10-03 13:41:57.118790241 +0300
> +++ linux/scripts/ver_linux    2015-10-03 13:48:49.277622632 +0300
> @@ -11,8 +11,12 @@
>  uname -a
>  echo ' '
>
> -gcc -dumpversion 2>&1| awk \
> -'NR==1{print "Gnu C                 ", $1}'
> +test -x "$gcc" &&
> +$gcc -dumpversion 2>&1 |
> +sed '
> +    /^[0-9\.]*$/!d
> +    s/^/GNU C\t\t\t/
> +'

I'm not sure whether replacing a bog standard idiom with a non-trivial
sed expression
is a good idea.
Your argument that currently the version has to be the first field is weak,
your script has a even stronger assumption, it assumes that the
version is field 1
_and_ has too be numeric.
But maybe I'm misinterpreting your regex, regex is hard to read for a human. :)

IMHO we should keep things simple. It's not that ver_linux (and other
scripts you patch) are hot paths
in the kernel build process.

-- 
Thanks,
//richard
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ