lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 20 Nov 2015 17:21:45 +0800
From:	Peter Chen <peter.chen@...escale.com>
To:	Marek Szyprowski <m.szyprowski@...sung.com>
CC:	<linux-usb@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
	"Ruslan Bilovol" <ruslan.bilovol@...il.com>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@...sung.com>
Subject: Re: [PATCH v6 1/4] usb: gadget: bind UDC by name passed via
 usb_gadget_driver structure

On Fri, Nov 20, 2015 at 09:54:09AM +0100, Marek Szyprowski wrote:
> From: Ruslan Bilovol <ruslan.bilovol@...il.com>
> 
> Introduce new 'udc_name' member to usb_gadget_driver structure.
> The 'udc_name' is a name of UDC that usb_gadget_driver should
> be bound to. If udc_name is NULL, it will be bound to any
> available UDC.
> 
> Tested-by: Maxime Ripard <maxime.ripard@...e-electrons.com>
> Signed-off-by: Ruslan Bilovol <ruslan.bilovol@...il.com>
> Signed-off-by: Marek Szyprowski <m.szyprowski@...sung.com>
> ---
>  drivers/usb/gadget/udc/udc-core.c | 24 +++++++++++++++++++-----
>  include/linux/usb/gadget.h        |  4 ++++
>  2 files changed, 23 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/usb/gadget/udc/udc-core.c b/drivers/usb/gadget/udc/udc-core.c
> index f660afb..429d64e 100644
> --- a/drivers/usb/gadget/udc/udc-core.c
> +++ b/drivers/usb/gadget/udc/udc-core.c
> @@ -549,21 +549,35 @@ EXPORT_SYMBOL_GPL(usb_udc_attach_driver);
>  int usb_gadget_probe_driver(struct usb_gadget_driver *driver)
>  {
>  	struct usb_udc		*udc = NULL;
> -	int			ret;
> +	int			ret = -ENODEV;
>  
>  	if (!driver || !driver->bind || !driver->setup)
>  		return -EINVAL;
>  
>  	mutex_lock(&udc_lock);
> -	list_for_each_entry(udc, &udc_list, list) {
> -		/* For now we take the first one */
> -		if (!udc->driver)
> +	if (driver->udc_name) {
> +		list_for_each_entry(udc, &udc_list, list) {
> +			ret = strcmp(driver->udc_name, dev_name(&udc->dev));
> +			if (!ret)
> +				break;
> +		}
> +		if (ret)
> +			ret = -ENODEV;
> +		else if (udc->driver)
> +			ret = -EBUSY;
> +		else
>  			goto found;
> +	} else {
> +		list_for_each_entry(udc, &udc_list, list) {
> +			/* For now we take the first one */
> +			if (!udc->driver)
> +				goto found;
> +		}
>  	}
>  
>  	pr_debug("couldn't find an available UDC\n");
>  	mutex_unlock(&udc_lock);
> -	return -ENODEV;
> +	return ret;
>  found:
>  	ret = udc_bind_to_driver(udc, driver);
>  	mutex_unlock(&udc_lock);
> diff --git a/include/linux/usb/gadget.h b/include/linux/usb/gadget.h
> index 3d583a1..b32e44f 100644
> --- a/include/linux/usb/gadget.h
> +++ b/include/linux/usb/gadget.h
> @@ -1012,6 +1012,8 @@ static inline int usb_gadget_activate(struct usb_gadget *gadget)
>   * @reset: Invoked on USB bus reset. It is mandatory for all gadget drivers
>   *	and should be called in_interrupt.
>   * @driver: Driver model state for this driver.
> + * @udc_name: A name of UDC this driver should be bound to. If udc_name is NULL,
> + * 	this driver will be bound to any available UDC.
>   *
>   * Devices are disabled till a gadget driver successfully bind()s, which
>   * means the driver will handle setup() requests needed to enumerate (and
> @@ -1072,6 +1074,8 @@ struct usb_gadget_driver {
>  
>  	/* FIXME support safe rmmod */
>  	struct device_driver	driver;
> +
> +	char			*udc_name;
>  };
>  

When trying to apply for testing, I meet below warning:

Applying: usb: gadget: bind UDC by name passed via usb_gadget_driver
structure
WARNING: please, no space before tabs
#55: FILE: include/linux/usb/gadget.h:1016:
+ * ^Ithis driver will be bound to any available UDC.$

>  
> -- 
> 1.9.2
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 

Best Regards,
Peter Chen
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ