lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 07 Dec 2015 17:36:07 +0800
From:	Hanjun Guo <hanjun.guo@...aro.org>
To:	fu.wei@...aro.org, linux-kernel@...r.kernel.org,
	linux-arm-kernel@...ts.infradead.org, linux-acpi@...r.kernel.org,
	linaro-acpi@...ts.linaro.org, jon.zhixiong.zhang@...il.com,
	tomasz.nowicki@...aro.org, tn@...ihalf.com, rjw@...ysocki.net,
	lenb@...nel.org, jarkko.nikula@...ux.intel.com
CC:	graeme.gregory@...aro.org, al.stone@...aro.org, jcm@...hat.com,
	mark.rutland@....com, catalin.marinas@....com, will.deacon@....com,
	msalter@...hat.com, Marc.Zyngier@....com, grant.likely@...aro.org,
	rrichter@...ium.com, lorenzo.pieralisi@....com,
	rruigrok@...eaurora.org, harba@....qualcomm.com
Subject: Re: [PATCH v3] acpi, apei, arm64: APEI initial support for aarch64.

Hi Fu Wei,

On 12/04/2015 01:15 AM, fu.wei@...aro.org wrote:
> From: Tomasz Nowicki <tomasz.nowicki@...aro.org>
>
> This commit provides APEI arch-specific bits for aarch64
>
> The reason for wrapping "acpi_disable_cmcff" by
> "#if defined(__i386__) || defined(__x86_64__)" in hest.c is:
> according to ACPI spec CMC(Corrected Machine Check) is only for IA-32
> Architecture.
>
> Changelog:
> v3: Remove "acpi_disable_cmcff" from arm64 code,
>      and wrap it in hest.c by "#if defined(__i386__) || defined(__x86_64__)"
>
> v2: https://lkml.org/lkml/2015/12/2/432
>      Rebase to latest kernel version(4.4-rc3).
>      Move arch_apei_flush_tlb_one() to arch/arm64/kernel/acpi.c
>
> v1: https://lkml.org/lkml/2015/8/14/199
>      Move arch_apei_flush_tlb_one() to arch/arm64/include/asm/apci.h.
>      Delete arch/arm64/kernel/apei.c.
>      Add "#ifdef CONFIG_ACPI_APEI" for "acpi_disable_cmcff".

The version updates is not belong here, if you need to add
it, please place it under "---" below.

>
> Signed-off-by: Tomasz Nowicki <tomasz.nowicki@...aro.org>
> Tested-by: Jonathan (Zhixiong) Zhang <zjzhang@...eaurora.org>
> Signed-off-by: Fu Wei <fu.wei@...aro.org>
> ---

...just here.

>   arch/arm64/Kconfig            | 1 +
>   arch/arm64/include/asm/acpi.h | 1 +
>   arch/arm64/kernel/acpi.c      | 6 ++++++
>   drivers/acpi/apei/hest.c      | 2 ++
>   4 files changed, 10 insertions(+)
>
> diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
> index 871f217..58c8992 100644
> --- a/arch/arm64/Kconfig
> +++ b/arch/arm64/Kconfig
> @@ -3,6 +3,7 @@ config ARM64
>   	select ACPI_CCA_REQUIRED if ACPI
>   	select ACPI_GENERIC_GSI if ACPI
>   	select ACPI_REDUCED_HARDWARE_ONLY if ACPI
> +	select HAVE_ACPI_APEI if ACPI
>   	select ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE
>   	select ARCH_HAS_ELF_RANDOMIZE
>   	select ARCH_HAS_GCOV_PROFILE_ALL
> diff --git a/arch/arm64/include/asm/acpi.h b/arch/arm64/include/asm/acpi.h
> index caafd63..7207f8e 100644
> --- a/arch/arm64/include/asm/acpi.h
> +++ b/arch/arm64/include/asm/acpi.h
> @@ -94,6 +94,7 @@ static inline const char *acpi_get_enable_method(int cpu)
>
>   #ifdef	CONFIG_ACPI_APEI
>   pgprot_t arch_apei_get_mem_attribute(phys_addr_t addr);
> +void arch_apei_flush_tlb_one(unsigned long addr);
>   #endif
>
>   #endif /*_ASM_ACPI_H*/
> diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
> index d1ce8e2..7a742e7 100644
> --- a/arch/arm64/kernel/acpi.c
> +++ b/arch/arm64/kernel/acpi.c
> @@ -32,6 +32,7 @@
>   #ifdef CONFIG_ACPI_APEI
>   # include <linux/efi.h>
>   # include <asm/pgtable.h>
> +# include <asm/tlbflush.h>
>   #endif
>
>   int acpi_noirq = 1;		/* skip ACPI IRQ initialization */
> @@ -233,4 +234,9 @@ pgprot_t arch_apei_get_mem_attribute(phys_addr_t addr)
>   		return __pgprot(PROT_NORMAL_NC);
>   	return __pgprot(PROT_DEVICE_nGnRnE);
>   }
> +
> +void arch_apei_flush_tlb_one(unsigned long addr)
> +{
> +	flush_tlb_kernel_range(addr, addr + PAGE_SIZE);
> +}

Maybe just a static inline function in arch/arm64/include/asm/acpi.h
will be good?

>   #endif
> diff --git a/drivers/acpi/apei/hest.c b/drivers/acpi/apei/hest.c
> index 20b3fcf..4ead747 100644
> --- a/drivers/acpi/apei/hest.c
> +++ b/drivers/acpi/apei/hest.c
> @@ -232,8 +232,10 @@ void __init acpi_hest_init(void)
>   		goto err;
>   	}
>
> +#if defined(__i386__) || defined(__x86_64__)
>   	if (!acpi_disable_cmcff)
>   		apei_hest_parse(hest_parse_cmc, NULL);
> +#endif

How about put it together into a function, and
introduce a stub function when no __i386__ and
__x86_64__ case?

Thanks
Hanjun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ