lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 14 Dec 2015 11:30:27 -0500
From:	Steven Rostedt <rostedt@...dmis.org>
To:	Borislav Petkov <bp@...en8.de>
Cc:	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] ftrace: Kill ftrace_caller_end label

On Mon, 14 Dec 2015 17:08:34 +0100
Borislav Petkov <bp@...en8.de> wrote:

> From: Borislav Petkov <bp@...e.de>
> 
> One of ftrace_caller_and and ftrace_return is redundant so unify them.

s/_and/_end/

> Rename ftrace_return to ftrace_epilogue to mean that everything after
> that label represents, like an afterword, work which happens *after* the
> ftrace call, e.g., the function graph tracer for one.
> 
> Beef up the comment about the code contents and layout before
> ftrace_epilogue label.

According to http://www.thefreedictionary.com/epilog

ep·i·logue also ep·i·log  (ĕp′ə-lôg′, -lŏg′) (n).
1.
   a. A short poem or speech spoken directly to the audience following
   the conclusion of a play.

Hmm, that doesn't fit.

   b. The performer who delivers such a short poem or speech.

Maybe people can think ftrace as a poem. But people will never think
that I give such a short speech.

2. A short addition or concluding section at the end of a literary
   work, often dealing with the future of its characters. Also called
   afterword.

Ah, "afterword" also doesn't fit, unless you mean "characters" as a set
of "char []". Which I guess the trampoline would fit.

3. An event which reflects meaningfully on a recently ended conflict or
   struggle.

Ah! This looks like the best match! Thus, this should be stated in the
changelog!

> 
> Signed-off-by: Borislav Petkov <bp@...e.de>
> Cc: Steven Rostedt <rostedt@...dmis.org>

Reviewed-by: Steven Rostedt <rostedt@...dmis.org>

-- Steve

> ---
>  arch/x86/kernel/ftrace.c    | 11 +++++------
>  arch/x86/kernel/mcount_64.S | 14 ++++++++------
>  2 files changed, 13 insertions(+), 12 deletions(-)
> 
> diff --git a/arch/x86/kernel/ftrace.c b/arch/x86/kernel/ftrace.c
> index 311bcf338f07..26ad092ac0dc 100644
> --- a/arch/x86/kernel/ftrace.c
> +++ b/arch/x86/kernel/ftrace.c
> @@ -690,9 +690,8 @@ static inline void tramp_free(void *tramp) { }
>  #endif
>  
>  /* Defined as markers to the end of the ftrace default trampolines */
> -extern void ftrace_caller_end(void);
>  extern void ftrace_regs_caller_end(void);
> -extern void ftrace_return(void);
> +extern void ftrace_epilogue(void);
>  extern void ftrace_caller_op_ptr(void);
>  extern void ftrace_regs_caller_op_ptr(void);
>  
> @@ -739,7 +738,7 @@ create_trampoline(struct ftrace_ops *ops, unsigned int *tramp_size)
>  		op_offset = (unsigned long)ftrace_regs_caller_op_ptr;
>  	} else {
>  		start_offset = (unsigned long)ftrace_caller;
> -		end_offset = (unsigned long)ftrace_caller_end;
> +		end_offset = (unsigned long)ftrace_epilogue;
>  		op_offset = (unsigned long)ftrace_caller_op_ptr;
>  	}
>  
> @@ -747,7 +746,7 @@ create_trampoline(struct ftrace_ops *ops, unsigned int *tramp_size)
>  
>  	/*
>  	 * Allocate enough size to store the ftrace_caller code,
> -	 * the jmp to ftrace_return, as well as the address of
> +	 * the jmp to ftrace_epilogue, as well as the address of
>  	 * the ftrace_ops this trampoline is used for.
>  	 */
>  	trampoline = alloc_tramp(size + MCOUNT_INSN_SIZE + sizeof(void *));
> @@ -765,8 +764,8 @@ create_trampoline(struct ftrace_ops *ops, unsigned int *tramp_size)
>  
>  	ip = (unsigned long)trampoline + size;
>  
> -	/* The trampoline ends with a jmp to ftrace_return */
> -	jmp = ftrace_jmp_replace(ip, (unsigned long)ftrace_return);
> +	/* The trampoline ends with a jmp to ftrace_epilogue */
> +	jmp = ftrace_jmp_replace(ip, (unsigned long)ftrace_epilogue);
>  	memcpy(trampoline + size, jmp, MCOUNT_INSN_SIZE);
>  
>  	/*
> diff --git a/arch/x86/kernel/mcount_64.S b/arch/x86/kernel/mcount_64.S
> index 87e1762e2bca..ed48a9f465f8 100644
> --- a/arch/x86/kernel/mcount_64.S
> +++ b/arch/x86/kernel/mcount_64.S
> @@ -168,12 +168,14 @@ GLOBAL(ftrace_call)
>  	restore_mcount_regs
>  
>  	/*
> -	 * The copied trampoline must call ftrace_return as it
> +	 * The copied trampoline must call ftrace_epilogue as it
>  	 * still may need to call the function graph tracer.
> +	 *
> +	 * The code up to this label is copied into trampolines so
> +	 * think twice before adding any new code or changing the
> +	 * layout here.
>  	 */
> -GLOBAL(ftrace_caller_end)
> -
> -GLOBAL(ftrace_return)
> +GLOBAL(ftrace_epilogue)
>  
>  #ifdef CONFIG_FUNCTION_GRAPH_TRACER
>  GLOBAL(ftrace_graph_call)
> @@ -244,14 +246,14 @@ GLOBAL(ftrace_regs_call)
>  	popfq
>  
>  	/*
> -	 * As this jmp to ftrace_return can be a short jump
> +	 * As this jmp to ftrace_epilogue can be a short jump
>  	 * it must not be copied into the trampoline.
>  	 * The trampoline will add the code to jump
>  	 * to the return.
>  	 */
>  GLOBAL(ftrace_regs_caller_end)
>  
> -	jmp ftrace_return
> +	jmp ftrace_epilogue
>  
>  END(ftrace_regs_caller)
>  

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ