lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed,  3 Feb 2016 12:33:28 +0100
From:	Borislav Petkov <bp@...en8.de>
To:	X86 ML <x86@...nel.org>
Cc:	LKML <linux-kernel@...r.kernel.org>
Subject: [PATCH 00/17] x86/microcode: Untangle loader from BLK_DEV_INITRD

From: Borislav Petkov <bp@...e.de>

Hi,

here are a bunch of patches untangling the loader dependency from
BLK_DEV_INITRD and fixing the builtin microcode loading on Intel. So
we're basically supporting two early-loading methods, one is the builtin
microcode in the kernel (CONFIG_EXTRA_FIRMWARE) and the detached initrd.
Both are described in Documentation/x86/early-microcode.txt.

First two are CC:stable <#4.4> so that the fallout from the merge of the
early and late loader is addressed.

The rest is smallish fixes and more cleanup to the Intel loader,
hopefully making it more readable.

Thanks.

Borislav Petkov (16):
  x86/microcode: Untangle from BLK_DEV_INITRD
  x86/microcode/intel: Make early loader look for builtin microcode too
  x86/microcode: Remove redundant __setup() param parsing
  x86/microcode: Issue update message only once
  x86/microcode/AMD: Drop redundant printk prefix
  x86/microcode/intel: Rename local variables of type struct
    mc_saved_data
  x86/microcode/intel: Rename mc_saved_count to num_saved
  x86/microcode/intel: Rename mc_intel variable to mc
  x86/microcode/intel: Move the BUG_ON up and turn it into WARN_ON
  x86/microcode/intel: Cleanup apply_microcode_intel()
  x86/microcode/intel: Use *wrmsrl variants
  x86/microcode/intel: Rename mc_saved_in_initrd
  x86/microcode/intel: Remove unused arg of
    get_matching_model_microcode()
  x86/microcode/intel: Cleanup get_matching_model_microcode()
  x86/microcode/AMD: Issue microcode updated message later
  x86/microcode: Document builtin microcode loading method

Dan Carpenter (1):
  x86/microcode: Remove an unneeded NULL check

 Documentation/x86/early-microcode.txt |  25 +++
 arch/x86/Kconfig                      |  27 ++--
 arch/x86/include/asm/microcode.h      |  26 ++++
 arch/x86/kernel/cpu/microcode/amd.c   |  11 +-
 arch/x86/kernel/cpu/microcode/core.c  |  17 +-
 arch/x86/kernel/cpu/microcode/intel.c | 281 +++++++++++++++++-----------------
 6 files changed, 213 insertions(+), 174 deletions(-)

-- 
2.3.5

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ