lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:	Wed, 29 Jun 2016 17:35:58 +0200
From:	Juergen Gross <jgross@...e.com>
To:	Jan Beulich <JBeulich@...e.com>,
	Amitoj Kaur Chawla <amitoj1606@...il.com>
Cc:	david.vrabel@...rix.com, x86@...nel.org, tglx@...utronix.de,
	julia.lawall@...6.fr, xen-devel@...ts.xenproject.org,
	boris.ostrovsky@...cle.com, mingo@...hat.com,
	linux-kernel@...r.kernel.org, hpa@...or.com
Subject: Re: [Xen-devel] [PATCH] x86/xen: Use DIV_ROUND_UP

On 29/06/16 17:34, Jan Beulich wrote:
>>>> On 29.06.16 at 17:00, <amitoj1606@...il.com> wrote:
>> --- a/arch/x86/xen/enlighten.c
>> +++ b/arch/x86/xen/enlighten.c
>> @@ -591,7 +591,7 @@ static void xen_load_gdt(const struct desc_ptr *dtr)
>>  {
>>  	unsigned long va = dtr->address;
>>  	unsigned int size = dtr->size + 1;
>> -	unsigned pages = (size + PAGE_SIZE - 1) / PAGE_SIZE;
>> +	unsigned pages = DIV_ROUND_UP(size, PAGE_SIZE);
>>  	unsigned long frames[pages];
>>  	int f;
>>  
>> @@ -640,7 +640,7 @@ static void __init xen_load_gdt_boot(const struct desc_ptr *dtr)
>>  {
>>  	unsigned long va = dtr->address;
>>  	unsigned int size = dtr->size + 1;
>> -	unsigned pages = (size + PAGE_SIZE - 1) / PAGE_SIZE;
>> +	unsigned pages = DIV_ROUND_UP(size, PAGE_SIZE);
>>  	unsigned long frames[pages];
>>  	int f;
>>  
> 
> Perhaps even more readable would be PFN_DOWN()?

Or PFN_UP() to be correct?


Juergen

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ