lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 01 Aug 2016 15:23:43 +0100
From:	Luis de Bethencourt <luisbg@....samsung.com>
To:	Salah Triki <salah.triki@...il.com>, akpm@...ux-foundation.org,
	viro@...iv.linux.org.uk
CC:	mhocko@...e.com, vdavydov@...tuozzo.com,
	linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 6/6] fs: befs: remove ret variable

On 31/07/16 21:34, Salah Triki wrote:
> ret is initialized to -EIO and is never modified, so remove ret and use
> -EIO directly.
> 
> Signed-off-by: Salah Triki <salah.triki@...il.com>
> ---
>  fs/befs/linuxvfs.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/fs/befs/linuxvfs.c b/fs/befs/linuxvfs.c
> index 2b68c81..c57f831 100644
> --- a/fs/befs/linuxvfs.c
> +++ b/fs/befs/linuxvfs.c
> @@ -300,7 +300,6 @@ static struct inode *befs_iget(struct super_block *sb, unsigned long ino)
>  	struct befs_sb_info *befs_sb = BEFS_SB(sb);
>  	struct befs_inode_info *befs_ino;
>  	struct inode *inode;
> -	long ret = -EIO;
>  
>  	befs_debug(sb, "---> %s inode = %lu", __func__, ino);
>  
> @@ -422,7 +421,7 @@ static struct inode *befs_iget(struct super_block *sb, unsigned long ino)
>        unacquire_none:
>  	iget_failed(inode);
>  	befs_debug(sb, "<--- %s - Bad inode", __func__);
> -	return ERR_PTR(ret);
> +	return ERR_PTR(-EIO);
>  }
>  
>  /* Initialize the inode cache. Called at fs setup.
> 

Hi Salah,

This one is a nice catch, since your patch also makes the code more readable.
No need to check the value of ret when you read that return ERR_PTR() anymore.

This has been this way since the introduction of ret in commit
96eb5419412fbc7f39fa45d987034c5d0e6e1202.
No need to add a "Fixes" tag in the commit message because that commit was 8
years ago.

Acked-by: Luis de Bethencourt <luisbg@....samsung.com>

Thanks :)
Luis

Pushed to the befs-next branch:
https://github.com/luisbg/linux-befs/tree/befs-next

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ