lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 2 Aug 2016 09:57:19 -0400 (EDT)
From:	Alan Stern <stern@...land.harvard.edu>
To:	Baole Ni <baolex.ni@...el.com>
cc:	rjw@...ysocki.net, <viresh.kumar@...aro.org>,
	<jarkko.sakkinen@...ux.intel.com>,
	<jgunthorpe@...idianresearch.com>, <hpa@...or.com>,
	<x86@...nel.org>, <linux-pm@...r.kernel.org>,
	<linux-kernel@...r.kernel.org>, <chuansheng.liu@...el.com>,
	<jslaby@...e.cz>, <peter@...sgaard.com>, <lee.jones@...aro.org>
Subject: Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro

On Tue, 2 Aug 2016, Baole Ni wrote:

> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.

This reasoning is highly questionable.  How does using a macro improve 
either robustness or readability?

> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
>  drivers/cpufreq/powernow-k7.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c
> index 9f013ed..2c7d73a 100644
> --- a/drivers/cpufreq/powernow-k7.c
> +++ b/drivers/cpufreq/powernow-k7.c
> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
>  	cpufreq_unregister_driver(&powernow_driver);
>  }
>  
> -module_param(acpi_force,  int, 0444);
> +module_param(acpi_force,  int, S_IRUSR | S_IRGRP | S_IROTH);

This is an excellent example.  To me, 0444 is _much_ more readable and 
understandable than S_IRUSR | S_IRGRP | S_IROTH.

Alan Stern

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ