lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 24 Aug 2016 07:55:56 +0200
From:   Andrzej Hajda <a.hajda@...sung.com>
To:     Milo Kim <woogyom.kim@...il.com>, Kukjin Kim <kgene@...nel.org>,
        Krzysztof Kozlowski <k.kozlowski@...sung.com>,
        David Airlie <airlied@...ux.ie>
Cc:     devicetree@...r.kernel.org, linux-samsung-soc@...r.kernel.org,
        Seung-Woo Kim <sw0312.kim@...sung.com>,
        linux-kernel@...r.kernel.org, dri-devel@...ts.freedesktop.org,
        Kyungmin Park <kyungmin.park@...sung.com>,
        Rob Herring <robh+dt@...nel.org>,
        linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH v2 3/4] gpu: drm: exynos_hdmi: Use consolidated function on
 binding DDC DT property

On 08/24/2016 04:25 AM, Milo Kim wrote:
> Handle legacy and raw 'ddc' parsing in single function.
> And it also removes goto condition.
>
> Cc: Kukjin Kim <kgene@...nel.org>
> Cc: Krzysztof Kozlowski <k.kozlowski@...sung.com>
> Cc: David Airlie <airlied@...ux.ie>
> Cc: Inki Dae <inki.dae@...sung.com>
> Cc: Joonyoung Shim <jy0922.shim@...sung.com>
> Cc: Seung-Woo Kim <sw0312.kim@...sung.com>
> Cc: Kyungmin Park <kyungmin.park@...sung.com>
> Cc: Rob Herring <robh+dt@...nel.org>
> Cc: devicetree@...r.kernel.org
> Cc: linux-arm-kernel@...ts.infradead.org
> Cc: linux-samsung-soc@...r.kernel.org
> Cc: linux-kernel@...r.kernel.org
> Cc: dri-devel@...ts.freedesktop.org
> Signed-off-by: Milo Kim <woogyom.kim@...il.com>
> ---
>  drivers/gpu/drm/exynos/exynos_hdmi.c | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/exynos/exynos_hdmi.c b/drivers/gpu/drm/exynos/exynos_hdmi.c
> index 2275efe..6a636f2 100644
> --- a/drivers/gpu/drm/exynos/exynos_hdmi.c
> +++ b/drivers/gpu/drm/exynos/exynos_hdmi.c
> @@ -1760,7 +1760,7 @@ static const struct component_ops hdmi_component_ops = {
>  	.unbind = hdmi_unbind,
>  };
>  
> -static struct device_node *hdmi_legacy_ddc_dt_binding(struct device *dev)
> +static struct device_node *hdmi_ddc_dt_binding(struct device *dev)
>  {
>  	const char *compatible_str = "samsung,exynos4210-hdmiddc";
>  	struct device_node *np;
> @@ -1769,7 +1769,13 @@ static struct device_node *hdmi_legacy_ddc_dt_binding(struct device *dev)
>  	if (np)
>  		return of_get_next_parent(np);
>  
> -	return NULL;
> +	np = of_parse_phandle(dev->of_node, "ddc", 0);
> +	if (!np)
> +		return NULL;
> +
> +	of_node_put(dev->of_node);
This is mistake introduced  by other patch, of_node_put should be called on
np, after calling of_find_i2c_adapter_by_node. You can fix it in your
patch as well.
I think you can move of_find_i2c_adapter_by_node also to this function and
rename it to sth like hdmi_get_ddc_adapter, this way you will enclose
whole logic
of getting resource into one function.

Regards
Andrzej

> +
> +	return np;
>  }
>  
>  static struct device_node *hdmi_legacy_phy_dt_binding(struct device *dev)
> @@ -1811,18 +1817,12 @@ static int hdmi_probe(struct platform_device *pdev)
>  		return ret;
>  	}
>  
> -	ddc_node = hdmi_legacy_ddc_dt_binding(dev);
> -	if (ddc_node)
> -		goto out_get_ddc_adpt;
> -
> -	ddc_node = of_parse_phandle(dev->of_node, "ddc", 0);
> +	ddc_node = hdmi_ddc_dt_binding(dev);
>  	if (!ddc_node) {
>  		DRM_ERROR("Failed to find ddc node in device tree\n");
>  		return -ENODEV;
>  	}
> -	of_node_put(dev->of_node);
>  
> -out_get_ddc_adpt:
>  	hdata->ddc_adpt = of_find_i2c_adapter_by_node(ddc_node);
>  	if (!hdata->ddc_adpt) {
>  		DRM_ERROR("Failed to get ddc i2c adapter by node\n");


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ