lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 6 Sep 2016 08:10:09 +0200
From:   Lukas Wunner <lukas@...ner.de>
To:     Matt Fleming <matt@...eblueprint.co.uk>
Cc:     linux-efi@...r.kernel.org,
        Andreas Noever <andreas.noever@...il.com>,
        Ard Biesheuvel <ard.biesheuvel@...aro.org>,
        linux-kernel@...r.kernel.org, x86@...nel.org
Subject: Re: [PATCH 1/2] x86/efi: Optimize away setup_gop32/64 if unused

On Mon, Sep 05, 2016 at 01:37:25PM +0100, Matt Fleming wrote:
> On Mon, 22 Aug, at 12:01:21PM, Lukas Wunner wrote:
> > Eliminate the 64 bit code path when compiling for x86_32, and vice-versa
> > the 32 bit code path when compiling for x86_64 with mixed mode disabled.
> > 
> > Size of gop.o text section:
> > CONFIG_X86_32:                         1758 before, 1299 after
> > CONFIG_X86_64 && !CONFIG_EFI_MIXED:    2201 before, 1406 after
> > CONFIG_X86_64 &&  CONFIG_EFI_MIXED:    2201 before and after
> > 
> > Signed-off-by: Lukas Wunner <lukas@...ner.de>
> > Cc: Ard Biesheuvel <ard.biesheuvel@...aro.org>
> > ---
> >  arch/x86/include/asm/efi.h | 6 ++++--
> >  1 file changed, 4 insertions(+), 2 deletions(-)
> > 
> > diff --git a/arch/x86/include/asm/efi.h b/arch/x86/include/asm/efi.h
> > index 6b06939..1bda245 100644
> > --- a/arch/x86/include/asm/efi.h
> > +++ b/arch/x86/include/asm/efi.h
> > @@ -207,14 +207,16 @@ struct efi_config {
> >  
> >  __pure const struct efi_config *__efi_early(void);
> >  
> > +#define efi_is_64bit()							\
> > +	(IS_ENABLED(CONFIG_X86_64) && (!IS_ENABLED(CONFIG_EFI_MIXED)	\
> > +				       || __efi_early()->is64))
> > +
> >  #define efi_call_early(f, ...)						\
> >  	__efi_early()->call(__efi_early()->f, __VA_ARGS__);
> >  
> >  #define __efi_call_early(f, ...)					\
> >  	__efi_early()->call((unsigned long)f, __VA_ARGS__);
> >  
> > -#define efi_is_64bit()		__efi_early()->is64
> > -
> >  extern bool efi_reboot_required(void);
> >  
> >  #else
> 
> Could you make this into a more readable static inline? e.g. something
> like this,
> 
> static inline bool efi_is_64bit(void)
> {
> 	if (!IS_ENABLED(CONFIG_X86_64))
> 		return false;
> 
> 	if (!IS_ENABLED(CONFIG_EFI_MIXED) || __efi_early()->is64)
> 		return true;
> 
> 	return false;
> }

Indeed this is much better. I've just sent out an updated version
in-reply-to the original patch.

Thanks a lot,

Lukas

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ